11
$\begingroup$

A scene I made is not rendering, at all.

Before: Before

After: enter image description here

Here are my settings:

enter image description here enter image description here enter image description here enter image description here

$\endgroup$
  • $\begingroup$ This usually happens when I get an error, like out of VRAM on my GPU or maybe an exception caused by a buggy addon. Usually if you render and it actually renders you will get transparency or a solid color. $\endgroup$ – VRM May 28 '16 at 15:08
29
$\begingroup$

Possible causes for blank output on rendering

(please follow the links in blue for further details)


Object has been disabled for rendering


Lights


Strips on the VSE


Object or camera are in a different render layer


Camera is blocked.

  • Is the camera behind a wall or another object?

  • Note that an object in front of the camera might be restricted from viewport display, making the issue not apparent in the viewport or render preview.


Camera is set incorrectly

  • The rendered image is that of the active camera's view. Not necessarily the view you have active in the 3d vieport. Press Numpad 0 to show camera view.

  • Active camera is aiming in a different direction.

    enter image description here

  • Wrong Camera being rendered.

    You can have multiple cameras in the scene, but only one can be set as the active camera for rendering. Check that you are using the correct one.

    In the properties window you can determine which camera is the active one

    enter image description here

    Or select the camera you want to make active in the viewport and press Ctrl+Numpad 0 to select the active camera.


Object as Camera

  • An object in the scene has been set as camera. Set the camera back to the active camera. To fix select the camera to be used as active camera.

    enter image description here


Output node disconnected

  • Output node in compositor might be disconnected. The composite node is the final output (not the viewer node).

    enter image description here


Wrong exposure


Clip Distance

  • The clip distance for the camera is set incorrectly.

    Make sure that you set the clip start and clip end so that the camera can see within a distance range that encompasses the scene. Geometry that is too close or further away than the set parameters will not render.

    enter image description here

    If your scene is too large or too small, if the scene is not within the range defined by the clip distance, then the camera will not "see the scene". Enable Display Limits on the camera to visualize the clip range.

    enter image description here


The scene is completely out of focus (blurry)

  • Focus for the camera set to 0 and lens aperture (f-stop) is set to a low value.

    The scene is so out of focus that you only see gray or some color that is predominant in the scene.

    To fix, change the distance value to the actual distance form the camera to your object, and maybe try a higher number for the f-stop.

    To find where your camera is focusing you can enable display->Limits. If you move the focus you'll see a cross mark that indicates where the focus point is:

    enter image description here

    A trick you can do is use an empty. Move the empty to the place you want the camera to focus on and select the empty (or any other object as the focus target).

    enter image description here

Read also this related post:

Why does my object not show up?

$\endgroup$
  • 1
    $\begingroup$ Having no lights wouldn't cause the result the OP is seeing, it would result in a black render. Same with setting a cube as the camera or incorrect render layers, you would still get some kind of render, even if it's the one you don't expect, which isn't what the OP has. $\endgroup$ – Ray Mairlot May 28 '16 at 15:39
  • 2
    $\begingroup$ @RayMairlot indeed, But since this question gets asked every other day I'm rehearsing a comprehensive answer that might help others troubleshoot... $\endgroup$ – cegaton May 28 '16 at 15:42
  • $\begingroup$ I understand that, I just think it may be confusing for users who have this specific problem to be trying out parts of your answer that aren't actually relevant to them. $\endgroup$ – Ray Mairlot May 28 '16 at 16:58
  • 1
    $\begingroup$ In my case, I tried everything possible to no avail then I realized that for some reason my UV Map got disconnected from the object and that's why the rendering of the object was black. In any case, I learned a lot from Cegaton's answer; it's always helpful to understand how to deal with this kind of problem in just one answer rather than spending the all day seeking for possible options. $\endgroup$ – Miracles Happen Aug 13 '18 at 6:13
  • $\begingroup$ I took the liberty to add a hint in the "Camera is blocked" paragraph: the camera might be blocked by an object restricted from viewport display. I hope it doesn't conflict with your answer @cegaton. $\endgroup$ – Nicola Sap Oct 15 '18 at 6:55
5
$\begingroup$

Restarting my computer did the trick. Was probably a RAM issue.

$\endgroup$
  • $\begingroup$ Yes, in this particular case (render shows blank screen with the grid), this was actually the right answer! Restart did the trick. $\endgroup$ – Artanis Mar 4 '18 at 16:22
1
$\begingroup$

This was happening to me and I had previously post processed an image and noticed the console mentioning post processing before the render would stop after 32 seconds. I turned off post processing in the render settings and my render would work again. Hope this helps

$\endgroup$
0
$\begingroup$

aha.....tracked it down to the fact that when I was messing about with the mist with the compositor nodes I had left the use nodes and back drop buttons selected .....as there was no longer anything to 'composite' there was no longer anything to output I presume.....anyway sorted now. Another 3 hours of misery lol.

$\endgroup$
-3
$\begingroup$

Additionally I found that the focus needs to be set to a specific object in the depth of field pane. If no object is set, you will get a blank screen

$\endgroup$
  • 2
    $\begingroup$ It's perfectly acceptable to have no object as the depth of field focal point - you must have been experiencing some other problem. $\endgroup$ – Greg Zaal Feb 13 '17 at 19:17

protected by David Feb 13 '17 at 23:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.