17
$\begingroup$

This is meant to solve this problem once and for all. What is every reason an object isn't showing up in a render or viewport in when using the cycles render engine?

$\endgroup$
23
$\begingroup$

This is the overview. I am breaking up the parts into individual answers that we can link to from other questions. This is a community wiki, so feel free to add ones that need to be addressed completely in another answer. If you decide to add another answer, please follow the pattern that I used with the first individual answer. This will make it easy to send people to this question or a particular answer while knowing that their question will be answered completely.

Invisible to the render

  1. Camera icon is disabled in the outliner

  2. Render layer not showing in the compositor

  3. Render layer does not include scene layer or the objects are in a layer that is not renderable.

  4. Scene layer not selected
  5. Cycles camera visibility disabled in object settings
  6. Cycles material disables visibility to the camera
  7. Objects are not within the range set by the camera clipping
  8. Using the wrong scene
  9. Strips present in the VSE, and the sequencer box is enabled in the post process section
  10. Cycles: Exposure setting in the film section set to 0
  11. Depth of field not set properly making the whole scene blurry
  12. Object blocking the camera view
  13. An object has been set as the active camera.
  14. There are no lights on the scene or they are on a different layer.
  15. Objects have no faces
  16. The Solidify modifier takes over the object and is disabled in Viewport
  17. Duplication type set to 'Group' and no group is selected.
  18. Duplication issues (under the Object tab in the properties panel), e.g., duplication type is not 'None', and object has no childen, or set to 'Group' and no group is selected.
  19. Render layer In Node editor is muted (disabled)
  20. Cycles materials don't have a shader node
  21. Camera is not pointed at object
  22. Save your data to .blend before rendering with Cycles/Eevee (Blender 2.8)

Invisible in the viewport

  1. Object is hidden
  2. 3D view clipping distance set too high/low
  3. Scene layer not selected
  4. Using the wrong scene
  5. Object is moved far away
  6. Using local view
  7. View Border is active (Alt+B)

Note: I will be adding reference images, details, and links as time allows. Hopefully this will be helpful to someone. If you think of something that I missed, feel free to suggest an edit.


Questions about problems that have not yet been addressed

Why Does My Object Not Show in Rendered Shading Mode?

Why do some objects not show up in the camera view?

$\endgroup$
  • $\begingroup$ I'd like to add that if a object is hidden (by pressing 'H' when selected) it could also result in an incomplete scene, especially when your workflow uses the isolate parts function ' / ' alot. NOTE: There have been some bugs reported concerning this in the past. So it might be difficult to replicate. $\endgroup$ – Delagone Nov 18 '16 at 13:09
  • 1
    $\begingroup$ @Delagone The "H" is already mentioned. That is just a shortcut to disable the "eye" icon in the outliner. Local/global view is important, though. I'll add it soon. $\endgroup$ – JakeD Nov 18 '16 at 13:25
  • $\begingroup$ Also, this happens to me all the time, maybe it should be added to the answer: blender.stackexchange.com/questions/88765/… $\endgroup$ – MicroMachine Aug 24 '17 at 16:36
  • $\begingroup$ @MicroMachine Why don't you go ahead and edit this answer? $\endgroup$ – JakeD Aug 25 '17 at 2:16
  • $\begingroup$ @JakeD all done :) $\endgroup$ – MicroMachine Aug 25 '17 at 18:20
5
$\begingroup$

2. Render layer not showing in the compositor

Documentation: https://www.blender.org/manual/render/post_process/layers.html#render-layers

There are actually a few different ways to run into this kind of problem. I will divide this up into different cases. If the Use Nodes button is not checked (in the node editor), you will not have any of these problems.

Case 1:

What it will look like

The render layer image output is not connected to the composite (final output) node.

enter image description here

How to fix it

Connect the nodes in some way (this is the simplest case...there will likely be other nodes in between).

enter image description here


Case 2:

What it will look like

The wrong render layer is selected by the render layers node.

enter image description here

How to fix it

Change the render layers node to the correct render layer.

$\endgroup$
4
$\begingroup$

1. Camera icon is disabled in the outliner

Documentation: https://www.blender.org/manual/editors/outliner.html#object-level-restrictions

What it will look like

The object will not be able visible in the final render, but it may or may not be visible in the 3D view render and the 3D view's solid mode.

enter image description here

How to fix it

Enable the render icon in the outliner for the object, or (with the object selected) hit Ctrl+Alt+H.

$\endgroup$
3
$\begingroup$

1. Object is hidden

Another reason why something might be invisible in the viewport is because it is hidden. Usually what triggers this is an accidental press of the H key, or Shift+H. The H key hides anything selected from the viewport, whereas the Shift+H hides anything not selected.

What it will look like

You won't be able to see the object in your viewport. In the outliner, there will be a greyed out eye next to the object.

enter image description here

How to fix it

Pressing Alt+H will make any hidden objects appear again. Also, you can enable the eye icon in the outliner.

$\endgroup$
  • $\begingroup$ I already had this one in the overview list...I just didn't call it the same thing. $\endgroup$ – JakeD Nov 18 '16 at 18:51
  • $\begingroup$ Gotcha, i didn't even realize that the eye icon and Hothey H did the same thingxD $\endgroup$ – Pythogen Nov 18 '16 at 18:53
3
$\begingroup$

6. Using local view

This one is a bit trickier, but is pretty easy to avoid. Nevertheless, if you happen to hit the Numpad / key, you may hit this so it's important to put here.

What it looks like

When you switch to local mode, only the selected objects become visible in the active 3D view.

enter image description here

How to fix it

Switch to global mode by pressing Numpad /, or use View > View Global/Local.

$\endgroup$
1
$\begingroup$

15. Objects have no faces

What it will look like

A mesh may have edges and vertices, but no faces.

enter image description here

How to fix it

Right-click to select a few vertices, then press f to make a face that spans them.

enter image description here

Alternatively, you could add a skin modifier:

enter image description here

$\endgroup$
0
$\begingroup$

8. Using the wrong scene

What it will look like

An empty scene is selected. In this example, the scene "Scene" is empty, and a different scene "Scene 2" has things in it.

enter image description here

How to fix it

Use the drop-down to the left of the name to select a different scene:

enter image description here

Note that you can set Blender to set the current scene to be the same for when you switch screens by enabling "Global Scene" in the user preferences (User Prefs > Interface > Global Scene). Make sure to save the user settings.

enter image description here

$\endgroup$
0
$\begingroup$

22. Save data to .blend before rendering with Cycles/Eevee

I think it hasn't been mentioned that, at least in Blender 2.8, you need to save to a .blend before you can render the smoke (and before you can bake it).

$\endgroup$

protected by David Apr 3 '18 at 21:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.