1
$\begingroup$

enter image description hereI am following Blender Guru's donut tutorial on Youtube, and it was working fine until I started doing the coffee. Now, whenever I go into the render viewport the screen is completely black. Whenever I hide the donut and only render the coffee it works fine. What is the problem? None of the fixes I have found have worked.

$\endgroup$
3
  • 2
    $\begingroup$ please share the file $\endgroup$
    – Sanbaldo
    Mar 29 '20 at 22:43
  • $\begingroup$ Do you have any lights in the scene? Are they hidden, or visible? $\endgroup$ Mar 29 '20 at 23:20
  • $\begingroup$ drive.google.com/file/d/1A7zx71dbOqJqn1GejYZ1FoE4L8sQCIh0/… And yes there is a light in the scene. Whenever I hide the donut the coffee and plate render just fine. Also figured out that it is the donut specifically and not the icing or sprinkles. $\endgroup$ Mar 30 '20 at 16:12
1
$\begingroup$

It's not the donut - it's the material you are using. Whenever I choose other material the scene renders just fine, but with material nomber 3 and 6 everything goes black. It has to do something with the nodes you are using because when "Use nodes" is checked - it's black and when it's not checked it's normal.

enter image description here enter image description here

My advice is not to use these materials - make a new one. You can even make the same nodes but don't capy and paste them - folow Andrew's tutorial.

$\endgroup$
1
  • $\begingroup$ Thanks! This worked. $\endgroup$ Mar 30 '20 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.