0
$\begingroup$

I have been practicing some hard-surface modelling, and this is the approximate result I intended:

enter image description here

However, I am facing a problem while trying to model the part I've marked with a yellow line. This is my base mesh before applying a subdivision modifier: As you can see, I have added an inset and beveled some of the edges. enter image description here

enter image description here

Later, I added a subdivision surface modifier, and my problem begins: there seems to be a problem with the face orientation and the mesh, although I cannot figure it out: enter image description here

Steps which I have taken to solve the problem (but were fruitless) include: 1- Trying to Merge any extra vertices 2- Double checking face orientation 3- Checking that I have no extra polygons inside my object 4- Applied scale, etc.

I will also share the file: 63. D.blend

Any hints are welcome. Thank you!

$\endgroup$

2 Answers 2

3
$\begingroup$

The problem seems to be that the outer edge, lacking other supporting loops like your inner corner does, is being smoothed over a larger area, which intercepts the geometry in your finer section, causing an error in the normals.

Look at the difference in geometry density between the two sections marked red here:

enter image description here

As you know, subdivision modifiers smooth an area out by creating a curve of sorts between three vertices. But, if those corners are not supported in a consistent density, this can occur. Here's a very rough dramatisation of what seems to be happening here:

enter image description here

See how the inner curve (pink) has less distance to smooth out, but the larger curve (blue) is smoothing out over a longer distance and intercepting the denser geometry?

This can be solved by supporting your geometry more, or by adjusting the edge crease to force the smoothed geometry to cling to the original positions a bit more.

$\endgroup$
3
$\begingroup$

Your topology is such that when you enable a Subdivision Surface modifier, it bends some faces so much that they overlap, you can fix that with this topology:

enter image description here

You don't have overlapping faces anymore:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.