1
$\begingroup$

I am trying to model a simple piece of a sniper scope. For that I am using a Bevel and Subdivision modifier to get clean and crisp edges when raising the model's resolution.

this is what the topology looks like without any modifier active:

As you can see it is based on a simple cylinder, nothing fancy. Next you can see the beveled topology. I want each beveled edge to stay sharp when subdividing.

enter image description here

However when I add the subdivision modifier on top I get a weird pinching effect in the areas I marked red. see the image:

enter image description here

I have to admit this is a problem that comes around pretty often but I never figured out how to fix it yet. I already tried adding some support loops, but it is important to me to keep the perfect circular shape of the scope part.

If you are reading this and know what to do in this case I would be more than happy if you could give some advice. Please find the blend file attached.

blend file blend file from pasteall.org

$\endgroup$
7
  • $\begingroup$ Hello :). I believe RobinBetts and Leander adressed this in some older thread... $\endgroup$ Apr 7 at 7:52
  • 1
    $\begingroup$ Here it is: How to avoid pinching on concave shapes with the bevel modifier and subsurf? $\endgroup$ Apr 7 at 7:53
  • $\begingroup$ @jachymMichal thanks for your reply! I already came across his answer, but his solution relies on additional edge loops. As soon as I add additional edge loops to my model I break the circular edge flow of the scope and the silhouette is no more perfectly circular from the front view $\endgroup$ Apr 7 at 8:02
  • $\begingroup$ Try setting the Miter outer to 'Arc' under Geometry in the Bevel modifier. $\endgroup$
    – John Eason
    Apr 7 at 8:22
  • $\begingroup$ @ Jachym Michal it doesn't matter, I NEED to ask!!!! $\endgroup$
    – moonboots
    Apr 7 at 8:25
2
$\begingroup$

You probably need more topology, like this (use a Shrinkwrap to make it stick to a cylinder shape):

enter image description here

The pinching is almost not noticeable:

enter image description here

If you want a better result I guess you need to add more topology:

enter image description here

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.