When I select all of my object in edit mode, and then go to texture paint mode, my object deselects and turn purple, and the UV map disappears. I've tried many methods to solve this problem but they didn't fully work, such as: Adding a new base color in order to add a texture to the UV map, but only some part of the head could be colored. I've also tried to redo the process, only for it to not work fully and properly. I will link a video and image of the problem more clearly.

The link to the video: https://youtu.be/bnNjaxyCPIU

The link of the image: https://i.sstatic.net/nQLNG.png

  • $\begingroup$ hello, how does your material look like? If you haven't created an image and plugged it into the Principlded BSDF (or Diffuse), it won't give anything (it will give this pink color) $\endgroup$
    – moonboots
    Commented Aug 3, 2021 at 14:46
  • $\begingroup$ I've used this link on how to texture paint, and not inserting an image. (Link is attached here) youtube.com/watch?v=AnRQhH3fEDY&ab_channel=SurfacedStudio $\endgroup$ Commented Aug 3, 2021 at 14:47
  • $\begingroup$ Also moonbots, what do you mean by inserting an image to the Principled BSDF? Im trying to texture paint and color the object with my cursor. I might be wrong about the previous statement. $\endgroup$ Commented Aug 3, 2021 at 14:51
  • $\begingroup$ If your statement is right, then help me on what to do in order to get rid of the pink color. $\endgroup$ Commented Aug 3, 2021 at 14:52
  • $\begingroup$ Hello and welcome. While files, images, and external videos or links may be helpful additions they should not be the only way to obtain information about your issue. Don't make understanding your question rely on downloading a file, watching a video or visiting an external site. Use the builtin tools to upload images or gifs, along with thoroughly explaining the problem in written form so it can be indexed and searched for thus helping future visitors with similar issues. $\endgroup$ Commented Aug 3, 2021 at 14:52

1 Answer 1


See the material you're using for the surface of your skull, it is called Union2Mtl and it has no Image Texture, you need to create an Image Texture and click on its New button (or select an already created image):

enter image description here

Also you need to make sure that the unwrap is correct (Smart UV Project will work fine for a 3D view painting) but it seems to be the case here.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .