0
$\begingroup$

I'm new to Blender, trying to use Texture Paint mode on a model I've made. I've got the texture and UV map set up right so far as I can tell, but when I try to paint on the object, the texture is painted on the back of the selected object.enter image description here

So when I tried to paint on the front half of the purple object, the white circle was painted on the back instead. The texture is not currently set up with nodes. Thanks in advance for the help.

$\endgroup$

2 Answers 2

4
$\begingroup$

Turns out I just had to fuss with some of the default settings, though why they were set to such an odd default, I don't know. For anybody else with a similar problem, this can be fixed by entering Texture Paint mode, then selecting Options > Project Paint on the left panel and making sure only Occlude is checked

$\endgroup$
2
  • $\begingroup$ Thanks for this! I had this problem just now and wouldn't have figured it out if it wasn't for this post. $\endgroup$
    – lakerice
    Commented May 21, 2020 at 4:50
  • $\begingroup$ Thank you, spent a ton of time backtracking my tutorial to find out what I was doing wrong! $\endgroup$
    – DogBot
    Commented May 28, 2022 at 16:09
1
$\begingroup$

Old post but a more probable root cause of that issue is inverted normals. it's easy to replicate by just creating any object, invert the normals and try to paint the texture, you will get exactly that effect, because the paint will be applied to the facing face in term of normal, not visibility. Even if you fixed your issue by using 'only Occlude', your model stayed all wrong in term of normals and should have been fixed in edit mode with alt- 'recalculate outside' or shift-n to recompute normals.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .