4
$\begingroup$

I'm using Blender 2.75, I made a model and UV mapped it to a black image, then colored it using texture paint mode brushes without problems as it was mostly solid colors with blurred transitions. Today I changed the mesh and had to unwrap again, but I lost parts of the texture and decided to paint it again.

The problem is that the brush now shows a weird grainy texture. I checked and no textures are assigned for the brush. I tried other brushes and they all present the same behavior. It's looks a pixelated brush that looks very ugly and I cannot make it soft no matter what I change.

The weird part is that the brushes work normally in the UV Image Editor. This only happens in texture paint mode if I paint directly on the model.

Could it be a bad setting? is this a common problem/bug? what can I try to solve this without losing the part of the texture that is correct?

Weird brush behaviour

$\endgroup$
  • $\begingroup$ check your UV map. After you edited the mesh, that might of messed it up. $\endgroup$ – David Sep 14 '15 at 1:15
  • $\begingroup$ I discovered it was the mirror modifier thanks $\endgroup$ – jeruki Sep 14 '15 at 17:18
1
$\begingroup$

I discovered that I had not applied the mirror modifier and that was causing the issue, apparently it was putting the model over itself and the brush did not know which one to paint.

After applying the mirror modifier and making sure I did not have double faces it worked fine.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.