1
$\begingroup$

I have a problem with the "Convert" button of my particle system : as soon as I click on the Convert button of the particles system modifier, my particles losses a part of their geometry (it is more rounded)

Here is the story (Apologizes if my english is hard to understand, I'm french, baguette) : I'm making asteroids belts.

So, I've created rocks affected by a subdivision modifier and a displace modifier with voronoi texture. Then I've duplicated it and scaled the rocks differently. Then, I've created a collection to put my rocks in.

Then I created a simple torus on which my rocks poped up thanks to a particle system. It is set as this : Particle System settings (1 by torus, so 1 by asteroid belt

I have plenty of particles system as this one, now I need to "bake" this into meshes (1 asteroid belt = 1 mesh).

To do that, here are my steps :

  1. Select Torus 1 (first particle system, first belt)
  2. Hit the Convert button on the Particle system modifier
  3. Object -> Relation -> Make Single User (Object & Data) so that every particle became the single user of its modifiers (the subdivision and displace modifiers inherited from the rocks i've created earlier as a source collection for my particle system)
  4. Object -> Convert to -> Mesh from Curve/Meta/Surf/Text
  5. Ctr-J : Now I have a unique mesh for the first asteroids belt (then I decimate it but anyway)

My problem is : Once I clicked on the convert button of a particle system, every rocks loses a part of its geometry, like if the Voronoi Texture used for the displace modifier losen its effect.

A particle BEFORE applying the Particle system with the convert button

Particle after hitting the convert button

How can I fix that ? I really need a strong texture for my scene.

By the way, the rock texture is just a noise node plugged in a bump node, then in the Normal input of a principled BSDF. So the displace modifier of a rock applies a Voronoi texture on it, then I bump the texture with a noise texture.

$\endgroup$
  • $\begingroup$ Which texture coordinates input are you using? $\endgroup$ – lemon Sep 1 at 15:29
  • $\begingroup$ It is a simple texture coordinate node (Object output) plugged in a mapping node (Vector input). Then mapping node -> noise texture. But again, is it a texture problem ? For me it is more about geometry, as my texture only applies a bump on the mesh. In any case, I use the Texture coordinate + Mapping with pretty every texture I use. I'm a begginer, I usually use it to coordinate a texture with a UV Map. In this case I don't really think it is usefull but I put it anyway... Here's a screen of the texture : nsa40.casimages.com/img/2020/09/01/200901054102901069.png $\endgroup$ – Pdhm Sep 1 at 15:40
  • $\begingroup$ ok, is the displacement modifier set to global coordinates or local? I presume this is global... Set it to local. Because when applyed, the relative size is totally different. $\endgroup$ – lemon Sep 1 at 16:04
2
$\begingroup$

When the particles are converted, they aquire their size as particle, so generally much smaller than the original object.

From that, if the displacement is set to "global" coordinates, the mapping of the object on the voronoi texture becomes very small and so has few variations.

As solution, set the displacement to "local" coordinates and the mapping will be equivalent between your original objects and the converted particles.

enter image description here

Alternatively, you can change (lower) the voronoi texture size once the particles are converted.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Ok it worked like a charm !! Sorry for my past comment I didnt know that you were asking for the Text Coordinate setting in the displace modifier haha I had to set this setting to Local for every rock references (29 haha...) and then modify the Voronoi Texture used for the displace modifier, as it gave me a slighty rounder displacement with this "Local" setting, as you said. But after this, Blender managed to convert those particles in a mesh that is perfectly the same ! Thank you ! :) $\endgroup$ – Pdhm Sep 1 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.