1
$\begingroup$

I needed more detail in this barrel that I made from flat plane and using curve modifier to bend it, but when I add more cutts they are ignored when bending and the shape stays the same as if they were not there. Also when I fast created new model it works just as expected and I have no idea why on my original model they are not working. There is also a problem with both of them creating these vertical distortions when shade smoothing.

.blend if needed: https://drive.google.com/drive/folders/1I_9nzNFiBAv7eToh8vH_j0HR5IoTEW5d?usp=sharing enter image description here

enter image description here

$\endgroup$
2
$\begingroup$

Here is what I found-all that that unnecessary loopcuts were causing the issue. It is probably because you used mirror modifiers to make the barrel. Mirror modifier just make a duplicate of the mesh and mirrors it. It does not merge the vertices to the original mesh.

In your case the easiest way to solve it is by selecting all those edges (which you have beveled) except any one among them by alt+shift + RMB and then delete them by pressing X.Dont forget to switch off all the modidifiers except curve modifier before selecting enter image description here enter image description here enter image description here(Select the edge and press Gtwice tp slide the edge) Which will get u this: enter image description here To solve it in the proper way, you can apply the mirror modifier and box select the vertices and merge them with altM > merge at center .(You wont even see the vertices cuz they are too close to each other).OR simply use the merge option in mirror modifier.

$\endgroup$
9
  • $\begingroup$ So when using the curve , the cuts should stay constant (not more here and less there) for the best result? $\endgroup$ – Michael Jul 30 '20 at 16:17
  • $\begingroup$ No What I meant was while using mirror modifiers the cuts should be constant $\endgroup$ – Nxdhin2005 Jul 30 '20 at 16:19
  • $\begingroup$ I recommend a cylinder to start with while creating it. I hope it is helpful. $\endgroup$ – Nxdhin2005 Jul 30 '20 at 16:20
  • $\begingroup$ Ah so the mirror creates the problem,thanks $\endgroup$ – Michael Jul 30 '20 at 16:28
  • $\begingroup$ You can select the answer as the accepted one if that helped you. Or else your question will be marked un answered. Happy that you found it helpfull ; ) $\endgroup$ – Nxdhin2005 Jul 30 '20 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.