0
$\begingroup$

I'm newish to blender and have been trying some stuff for fun. When in the Shading tab my two objects look like this enter image description here

But when in Layout tab it looks like this enter image description here

Is this because there is a lack of reflective surfaces in the layout workspace. Here is file just in case https://drive.google.com/drive/folders/1UDwYHPuKChcps8QVuM5N79nVDnfqTfBe?usp=sharing Sorry for google drive link. Hope you guys can help, thanks

$\endgroup$
3
  • 1
    $\begingroup$ Lookdev (first image) uses an environment lightning. This is not the case for rendered (second image) are you are supposed to choose the environment lightning yourself. See the button with circles on them, on top right of the 3D view. $\endgroup$
    – lemon
    Sep 19, 2019 at 6:20
  • $\begingroup$ So how do I set it to look like the lookdev lighting $\endgroup$ Sep 19, 2019 at 20:49
  • $\begingroup$ Use exr map as environment texture. You can find the one provided with Blender in your installation folder: C:\Program Files\Blender Foundation\Blender\2.80\datafiles\studiolights\world $\endgroup$
    – lemon
    Sep 20, 2019 at 5:46

1 Answer 1

0
$\begingroup$

Lookdev (first image in the question) uses an environment lightning. This is not the case for rendered (second image) are you are supposed to choose the environment lightning yourself.

See the button with circles on them, on top right of the 3D view:

enter image description here

If you want to have the same lightning in 'rendered' viewport shading, you can use the same texture that can be found in your installation path: \Blender Foundation\Blender\2.80\datafiles\studiolights\world.

And set the world surface like this, where forest.exr is from the folder above:

enter image description here

Though, the texture will be visible in the background and this is not the case in look dev shading mode.

If you don't want it, there is two (at least?) possibilities:

Either set the film to "transparent":

enter image description here

and the background will be transparent...

Or enhance the world node setting, using another color of your choice when the light ray goes directly to the camera:

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .