1
$\begingroup$

I can't get my GPU to work on any scene.

I have enabled both my CPU and GPU for Cycles rendering. But during render CPU usage gets to 100% and GPU does not go up (below 5%).

Here are my settings:

Preferences enter image description here

I tried unchecking the CPU in preferences, and in that case 10% of my CPU is working on the rendering.

The scene I am working on is not the problem because, I tried other scene, like the BMW benchmark for GPU. And still the GPU is not working.

I have all Nvidia drivers up to date (Game ready and Studio). I tried Blender 2.82a, and 2.83 no difference

I am looking for a solution, thank you for reading this.

$\endgroup$
  • $\begingroup$ How Big is your rendering tile size? It most likely you just set a tile size too big and there isn't much more tiles for 2070s to rendering thing (Since 3500 use 12 tiles). $\endgroup$ – HikariTW May 20 at 14:37
  • $\begingroup$ And I don't recommend you to render on both CPU and GPU since your CPU is not that good compare to 2070s, the improvement should be little and the rendering setting will be hard to control since they need different parameter to work best. (I recently use a 3900x with 1070ti, guess what, 1070ti is still way faster than 3900x) $\endgroup$ – HikariTW May 20 at 14:41
  • 1
    $\begingroup$ Thanks for your advice, I will use only the GPU. I tried different tile sizes but apprently my GPU was working correctly, it just that the task manager didn't show it clearly. $\endgroup$ – Lucas May 20 at 19:10
0
$\begingroup$

Same here.

Just a quick note: Windows Task Manager doesn't show CUDA utilization by default (which is what Cycles uses). To have that show up, click on the "3D" above the graph and choose "Cuda" or "Compute_0" in the drop down that pops up. It will then show correct utilization.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Thanks, I didn't know that. I checked and I'm at 100% cuda utilization, which means its working correctly I guess. My GPU was working fine I just thought it would appear in the overall GPU usage but apparently not. $\endgroup$ – Lucas May 20 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.