I've enabled GPU rendering (CUDA) for my GTX 1060 and it's awesome. 3D viewport views render much faster than before. Monitoring my GPU shows it at 60-100% usage while Cycles samples.

However, when rendering still images or animations to file, my GPU usage is flat or at zero as CPU usage spikes.

I'm running blender 2.79b on a win 10 system with one GPU.

Yes, I have the latest driver from Nvdia. (399.07)

Yes, I have gone to the Nvdia control panel and set the OpenGL rendering GPU to my card.

*Update. I seem to have located a bottleneck in GPU usage. Looking at MS Process Explorer, it seems that blender is only using, or only has use for part of the GPU..? I'm uncertain if the types of scenes I create is a factor in creating this bottleneck, or if the problem is a solvable blender config issue.

the little engine that could

  • Have you also set 'Device' to 'GPU Compute' in the Properties > Render tab > Render panel? (The option is left open, whether to use CPU or GPU, when using the Cycles renderer) – Robin Betts Sep 4 at 7:28
  • Yes I have set the Device to GPU Compute and my Feature Set is "Supported." – Russ Duckworth Sep 4 at 8:10
  • What is the size of the tiles in the render settings under Performance section? – Martin Z Sep 4 at 11:43
  • I've tested values from 64x64 up to 512x512. – Russ Duckworth Sep 4 at 22:47

Have you enable the CUDA options on "Cycles Compute Device" setting under the System tab on the Preference setting? If you didn't that may caused your problem enter image description here

  • Yes, Bogiva. As stated in the first sentence of my question. – Russ Duckworth Sep 4 at 9:18

MS Process Explorer does not accurately report GPU usage.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.