0
$\begingroup$

I bought a model that has a .blend file in the archive. I opened the .blend file with the Blender 2.82 on Mac (it couldn't be opened in 2.79, I get an error). But instead of the model, I saw the black object. I tried all 3 render engines: Eevee, Cycles, and Workbench. Only Workbench shows the object (though without the textures, but it's another problem). I need to use the Cycles render.

I'm totally new to Blender and have no clue what to do. I suppose that maybe some settings are wrong. I tried to google, but haven't found an answer yet.

UPDATE 1

The error I see if I try to open the model in Blender 2.79:

enter image description here

Also, here is the interface of Blender after I opened the file (the top menu is gone):

enter image description here

UPDATE 2:

Some of the objects in the model have UV Maps: here's one of them:

$\endgroup$
4
  • $\begingroup$ Could yoou tell us what kind of file you opened in blender, and what kind of error message you got? $\endgroup$ – copy paste Mar 26 '20 at 6:52
  • $\begingroup$ i think the model is older. Its from Blender internal. So all the 3 engine will not support. Open the file in 2.79 search for addon activate the -> convert to cycles. You can find the addon in Properties - material - convert to cycles. Just click on convert all to cycles.How preview render it i hope it will render. If so copy all the object paste in 2.82 $\endgroup$ – atek Mar 26 '20 at 7:50
  • $\begingroup$ I added the screenshot of the error in Blender 2.79 $\endgroup$ – Anastasia Apr 7 '20 at 19:49
  • $\begingroup$ Error says: "File written by newer Blender binary (280.0), expect loss of data". The scene is empty and also the top menu is gone, so I cannot open another file, etc. I have to close Blender and open it again. $\endgroup$ – Anastasia Apr 7 '20 at 20:08
2
$\begingroup$

Usually in "bought" models, created in other software you will find custom split normals.

To clear them click here:

enter image description here

Strange black shading. Cannot fully light mesh. (Cycles)

My model is not reflecting any light / looks dark

$\endgroup$
1
$\begingroup$

The problem might be because of various issues. Try these and see if any of those is useful in fixing the issue:

  1. Recalculate the Normals of the object ("Shift+N").

  2. Try disabling the "Auto Smooth" option in Object Data Properties-> Normals -> Auto smooth.

  3. Check if the UV maps are connected to the image textures of the object materials. For this, add a "UV map" node and select the respective UV map and connect it to the image texture.

  4. If you are having multiple UV maps for the object, make sure that the correct UV maps are turned on for the rendering: ( You can check this in Object Data Properties->UV Maps and click in the camera icon adjacent to the UV maps)

    See if any of these fixes the issue

$\endgroup$
1
  • $\begingroup$ I did the 1st and the 2nd and it didn't help. As for the other 2, I'm not sure. I added the screenshot of the UV map at one of the objects (Update 2). Does it mean that UV maps are connected? $\endgroup$ – Anastasia Apr 7 '20 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.