0
$\begingroup$

Hi I wanted to render my work on different machines - I tried to use both SheepIt Render Farm and Google Cloud Machines but both of the turn up with completely black renders. One time i managed to get something with changed colors from google cloud. Could you tell me where the problem is? I'm using Blender 2.79b Cycles - Experimental features (I know tha sheepit doesn't support it, but it just should render without it) I really care about Adaptive Subdivision. I append the blend file and the done render that I did. enter image description here (.blend file) https://drive.google.com/open?id=1cDffl04Jo1vVioZYEoN360yx7TA0ZIYj

$\endgroup$
  • $\begingroup$ My file exceeds 30 MB minimum $\endgroup$ – Konrad G Sep 4 '18 at 14:11
3
$\begingroup$

You need to connect the composite node to the tree (like your 'view' node is connected). On your local machine, you can see the image because you see the render layer. But if you render it with a 3rd party system - likely via command line, you need to have the composite (final output) node connected.

$\endgroup$
  • $\begingroup$ Thank you for help. I already found that fault but thanks anyway for the problem downloading and checking. You're the best! :D $\endgroup$ – Konrad G Sep 6 '18 at 10:05
1
$\begingroup$

Same Blender version installed on multiple computers and configured identically will produce identical results.

You need to make sure all the settings are the same as in the environment the scenes are going to be rendered in. I would recommend to test render with render border (ctrl+b in object mode in the Viewport looking through the camera,ctrl+alt+b to remove). You should make sure that you use identical Blender release, feature set and compute device settings or that it renders the same. You should also rename your preferences folder (%appdata%\Blender Foundation\Blender\[version number]) temporarily, restart Blender and make sure you do not have any plugins that may interfere with the render and also that your color management files are the same as in the rendering environment. Also make sure that all the textures are packed properly. That should do it. I am rendering on SheepIt even at the time I am writing this and it does indeed produce results exactly identical to the ones I get on my workstation computers.

$\endgroup$
  • $\begingroup$ I even copied my entire blender to Google's Virtual Machine and the case is still the same - the render is just pure black. It's no the case of missing texture $\endgroup$ – Konrad G Sep 4 '18 at 19:10
  • $\begingroup$ What about your preferences folder? $\endgroup$ – Martynas Žiemys Sep 4 '18 at 19:43
  • $\begingroup$ I tried to rename it and same thing happen. I found another thing now - if I render via command line same happens on my blender too - black image. Via GUI normal. Do you know what can be problem? $\endgroup$ – Konrad G Sep 4 '18 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.