1
$\begingroup$

I have a Base Mesh of a human male that I've purchased. Using the Armature that it came with, I've made some changes to it, such as making the model a bit taller, thinner chest, thicker legs etc... So basically I scaled and move some of the bones while in Pose Mode. If I go into Edit Mode for the Mesh or the Armature, it of course goes back to what it looked like at first. My goal is to have the Edit Mode look like my current Pose Mode.

Here's what I've tried:

  • I applied the Armature Modifier to the Mesh which makes the Mesh look the same both in Edit and Object Mode and that's what I wanted.
  • I then selected my Armature, went into Pose Mode, selected all the bones and CTRL+A > Apply Pose as Rest Pose. The Armature now looks the same in both Edit and Pose Mode.

The issue that I'm now having is that if I add a new Armature Modifier to the Mesh and then select my rig as its object, about 80% of it looks good, but in some areas it deforms pretty bad, it certainly doesn't look the same anymore. Am I doing things the wrong way or what am I missing?

Thank you in advance!

P.S. - Here's a video of what I've tried and my results: https://youtu.be/WuU03lvx3hI

$\endgroup$
  • $\begingroup$ Have you checked if the armature has some hidden bones in some hidden bone layers? Maybe you didn't select all bones while applying pose as rest pose. The procedure you did is correct, it should work. Maybe share your file or at least upload some images of the bad deforming areas. $\endgroup$ – josh sanfelici Sep 13 at 20:52
  • $\begingroup$ Hey, thank you so much for the reply! I just added a video showing what I've tried: youtu.be/WuU03lvx3hI :) $\endgroup$ – stefanplc Sep 13 at 21:27
  • $\begingroup$ At the beginning of the video I hide 2 bones to then show that I'm using ALT+H to unhide all hidden bones. $\endgroup$ – stefanplc Sep 13 at 21:28
1
$\begingroup$

The problem lies in the fact that when you selected all bones of the rig, you didn't select all "Machinary" bones, hidden in others bone layers. Go tot the properties tab, armature, bone layers, turn on every single layer, THEN check if any other bone is hidden (ALT H), then select all and apply pose as rest pose.

In my example picutre a classic Rigify rig, and the same rig with all the machinary bones revealed.

enter image description here

If that doesn't solve the problem, after you have applied your pose as rest pose, select the "bn chest" bone, in the bone constraints panel search for "stretch to" constraint and click the "RESET" button. Do the same with bn neck 01 and bn neck 02.

enter image description here

$\endgroup$
  • $\begingroup$ Thank you for taking the time to try and help me :) I've done what you asked for and made a video of it here: youtu.be/tJcq3meC8so While it still doesn't fix the issue, I think it does help identify the issue a bit better. When I Apply Pose as Rest Pose, the spine bones appear to increase in scale each time. Any idea what could be causing that? Thanks again! $\endgroup$ – stefanplc Sep 14 at 15:04
  • $\begingroup$ Hard to tell, you could upload the file (or, if you prefer, a file with the armature only) $\endgroup$ – josh sanfelici Sep 14 at 15:45
  • $\begingroup$ My only concern with uploading the file is that I didn't create this myself, it's a purchased asset. However, I deleted the mesh and most of the armature, I only left the part where I'm having the error. Please see the file here: pulciu.com/base_mesh_partial.blend . So if you select all the bones in Pose Mode and pick Apply Pose as Rest Pose, it works fine. If however first, you grab the ctrl_chest bone (the most bottom circle in the middle) and move it up a bit and THEN select all the bones and Apply Pose as Rest Pose, you'll see that the spine bone increases in scale each time. $\endgroup$ – stefanplc Sep 14 at 15:55
  • $\begingroup$ I've updated my answer, even I didn't know this strange behaviour of the "stretch to" constraint. $\endgroup$ – josh sanfelici Sep 14 at 17:45
  • $\begingroup$ Yep that did it! Thank you so much for your help! :D Now I can finally resume my work towards becoming the world's greatest game developer muahahaha! Again, really appreciate you taking the time and helping me figure this out :) $\endgroup$ – stefanplc Sep 15 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.