People who code: we want your input. Take the Survey

Questions tagged [armature]

An armature is a system of bones used for animating or deforming a mesh. Use this tag for questions pertaining to armatures.

Filter by
Sorted by
Tagged with
0
votes
0answers
11 views

Using Python, how do I list all the armatures in the scene and make the selected armature active?

I'll start by saying I'm fairly new to coding. I'm trying to code an add-on that has a drop-down list that'll list all the armatures in a scene and then make it so you can select an armature from that ...
0
votes
0answers
26 views

Problem animating chameleon-like eyes

I'm relatively new to everything involved with 3D modeling and I'm having some issues with animation in particular. I'm attempting to have these "Eyes" animate, looking in all different ...
1
vote
1answer
18 views

Selecting bones by name without clicking

Selecting bones can be pretty tedious, especially when you are switching back and forth between armatures. I wish that when I switch to pose mode, there was a way to typeahead search for a bone by ...
0
votes
0answers
7 views

How to rotate child bones using python + axis-angle rotation in pose-mode

I'm trying to rotate a child bone around a specific axis via a python script which gives me some trouble and I suspect the issue is the bone-to-world-space conversion I'm doing. In the case of the ...
0
votes
0answers
9 views

Hair particles don't follow armature deformed mesh

I have a mesh with a hair particle modifier on it along with an armature that is animated using the Wiggly Bones plugin. However, when running the animation, the hair kind of 'detaches' from the mesh, ...
0
votes
0answers
20 views

I can't move my 3d model from Blender to Mixamo [closed]

I created two female 3d models, one of the models has hair and texture and the other does not, the model with hair and texture cannot be added to mixamo with the error message "skeleton not found&...
0
votes
0answers
8 views

eyes object not following animated armature bones properly [closed]

Hello dear community members, Ok.. I'm feeling absolutely lost! I've started to dabble in blender about 3 weeks for now and I've got a problem with the animation rig. I've tried to find a solution for ...
0
votes
0answers
11 views

How can I fit a proxy to a model using MB-Lab?

I have created a human using MB-Lab 1.7.8 in Blender 2.92. I am trying to fit a proxy to the human object but it doesn't work. First I added the proxies (two high heeled shoes) and adjusted the rest ...
0
votes
0answers
11 views

Accessing and modifying a single bone's actual scale?

I'm working on a game production that uses 3Ds Max to model and animate characters, Unity as the engine that will receive the 3D assets and Blender for users to make custom models/mods for the game. I ...
0
votes
0answers
15 views

How can I change my bone positions after parenting objects to the bone?

I laid out all the bones in my armature and parented the parts of my model to the bones. So far so good. But, when setting constraints on one of the bones in Pose Mode, I noticed that it was slightly ...
0
votes
1answer
29 views

Automatic weight not working

I was trying to make a simple rig with a Low Poly Character but something went wrong with the automatic weight when parenting because is not working. I tried several times and I would really ...
1
vote
1answer
16 views

Can't see the armature

I made a character based on a tutorial, idk what i clicked or what happened but i can't see my armature, i tried unhiding(it doesn't even show if it is hided or no). It only shows in weight painting, ...
0
votes
0answers
7 views

Why doesn't armature move with keyframes?

I've got this animated animal thingy with keyframes, but when it moves the armature doesn't move with it, does anyone know how to fix that?
0
votes
1answer
11 views

Delete armature and bake animation / boolean

I have an object parented to an armature that is animated with a series of movements. I need to perform some boolean operations to this object in different frames of the animation, but if I just add a ...
0
votes
0answers
11 views

Mesh distorted by rig after export

I have a rigged and animated character that looks completely fine in blender (original .blend file). When I export it, the mesh gets distorted in some places. It looks like some of the vertices are ...
0
votes
1answer
13 views

Possiblity to transform an Object to Bone

I have a medical scan of a spine, I seperated all 24 vertebrae from each other in Meshlab and I wanted to use those as bones/armature for a Rig. But those are Objects and not Bones, can i use these 24 ...
0
votes
0answers
13 views

Final armature didn't include my character's middle fingers (rigify/uefy)

I Recently started rigging models and followed a youtube guide https://www.youtube.com/watch?v=mg75kSkKkug&t=2116s to rig my humanoid character for ue4, this is what happened after I build a ...
1
vote
0answers
27 views

How to change default bone rotation from Quaternion (WXYZ) to Euler (XYZ)?

For all the bone of an armature in pose mode, in the item/transform menu and on object properties/transform, the default mode is alway Quaternion (WXYZ). How can I change that to Euler XYZ for all ...
0
votes
1answer
16 views

Apply Pose as Rest pose doesn't work

Just as the title says. This is the pose I want to be the new rest pose: This is the current rest pose: But when I try to set my pose as rest pose, the armature becomes detached from the mesh, like ...
0
votes
1answer
17 views

Ctrl + L Copies Animation Data, but Animation Doesn't Play

Just like the title says. I'm copying animation data from one armature to another with CTRL+L. The animation data copies over, but the armature does nothing. Any idea? Edit: My file is 275mb with just ...
0
votes
2answers
21 views

Selecting bones with the same name

I'm writing a little picker for Blender. The principle of operation is simple. I select some armatures, go into pose mode. If I select bones, then bones with the same name in other armatures become ...
0
votes
1answer
11 views

Blender mesh move not corectly in Pose Mode despite WeightPaint and Removing Doubls

My mesh or the belt of my character is not moved properly with, in spite of Weight Paint and removing Doubles/ merge by distance. My Mesh; My Mesh when i pose and you can see that my belt ist ...
0
votes
1answer
18 views

Apply metarig armature to mesh

Is there any way to 'embedd' a pose from a metarig armature onto the connected mesh, so the armature can be applied/deleted without losing the pose? I'd like to do some dyntopo sculpting on a posed ...
0
votes
1answer
14 views

Whole mesh rotates with armature, not just the arms

I want to only make the arms of my armature move so I added an armature and parent the mesh to the armature using automatic weight. However when I rotate the armature the whole mesh moved, not just ...
0
votes
0answers
18 views

Parenting a skeleton to an armature explodes most of the mesh

When I parent a skeleton to an armature most of the skeleton mesh explodes forward. I have been working this model for a couple of weeks and this never happened before. The only difference it seems is ...
0
votes
1answer
9 views

I make an action editor animation using keyframes, I save and quit, then when I open it back up, my animations are gone

I am making an animation using Action Editor and key frames, I then go to save and quit, when I go back in, most of my animations are gone and only a few remain.
0
votes
0answers
7 views

Issues with bendy bones armature rigging and joining

I am currently having issues with rigging and armatures. I have a mouth armature I rigged a new way for me per a tutorial (https://youtu.be/5zmWmJLfspg) using bone constraints and drivers. I now want ...
0
votes
0answers
11 views

Armature Changes In Edit Mode when working in Object/Pose Mode

I want to rotate my armature in Object Mode to make my animation look better. But when I do this, my armatures t-pose in Edit Mode rotates too. How do I get it to not do that? I want to keep my Rest ...
0
votes
1answer
20 views

Generating rigging problem

Im trying to generate rig my character yet for some reason the rest of my generate rig for the body isnt appearing. Does this only work when it comes to the human meta rig?
0
votes
0answers
13 views

Blender WeightPaint Mode Colors Bug?

Picture(1) As you can see, I have selected the Subtract tool and there is an area that I want to paint blue. Picture (2) Now I used the Subtract tool to paint the area blue and the yellow becomes ...
0
votes
0answers
9 views

When I try to parent my mesh to my armature, my mesh jumps ahead and when rotating bones only certain parts of mesh come with it?

I have tried weight painting individual parts, every part is named correctly with the armature, the edit and rest pose of armature and mesh are the same. I have run out of options to try to fix this, ...
0
votes
0answers
15 views

Armature is resetting it's y position every time I open the blend file

For whatever reason, the armature ends up pinging off downwards whenever I open up the blend file, applying transformations, setting origin point, does nothing. The armature is where it needs to be in ...
0
votes
2answers
18 views

Mesh gets deformed after parenting with automatic weights

I've been trying to attach this character mesh to an armature using Armature Deform with Automatic Weights, but after setting the weights, the character gets its limbs shifted strangely (wrists turn ...
0
votes
0answers
10 views

Parenting with automatic weights destroys the object

I downloaded this mouse from the blender page and now I try to parent the object to the bones with automatic weights. but the object changes completely. This is before I parent the object to the bones....
0
votes
1answer
11 views

Mesh lagging behind another mesh in the same target bone

I am currently making a hinge armature and there are a few meshes that is attached to the target bone (via object constraints). It looks like this: However, when I rotate the selected bone on the X-...
0
votes
0answers
30 views

the same Animating my character's leg brings part of the other foot with it

I'm making a rabbit in blender and I parented my front and back foot and when i'm trying to animate, both my front foot and my back foot will move together. I want to separate the foots from moving ...
0
votes
0answers
14 views

Floor tiles gloss - match the Viewport Shading gloss for multiple rotated objects

I want to use 4 tiles to create a floor 1 for inner and outer corner each, 1 for the edges and a full one for the middle. With the rotations on each tile the gloss also changes with it like this https:...
0
votes
0answers
12 views

Leg of my model deforms when i parent rig with automatic weights

When i parent my rig to my model this happens - This only happens to one of the legs even though both of the legs are the same. How can i fix this?
0
votes
0answers
8 views

Why won't my armature move when I append it to another .blend?

I rigged a model and the armature moves fine in the .blend I have it in. However, when I transfer it to another blend file I can only move it through the pose library, not through pose mode. Any help ...
0
votes
1answer
21 views

I have a Mesh with an Armature. The Mesh has a “Mesh Deform” modifier, which itself has physics. Why does it break when Rendered?

I am probably missing something very obvious---maybe a modifier stack problem, more likely it's a parenting issue, or else I don't understand Mesh Deform well enough. This is a simplified example. ...
0
votes
0answers
6 views

Export to fbx jumbles object positions and fails to embed the texture of my rigged character. How can I fix it? 2.91.2

I have my rigged character here and I need help exporting as an fbx. You can see what the current export looks like in the paint 3d window of my screenshot, and yeah, it isn't pretty. The body parts, ...
0
votes
0answers
10 views

Armatures/Rig Deforms Mesh With Extreme Angles

I'm learning rigging and in the process of setting up a free spider man mesh (https://www.cgtrader.com/free-3d-models/character/man/base-mesh-spider-man) I noticed that in pose mode when doing extreme ...
1
vote
0answers
19 views

My mechanical rig bones in the eye aren't lining up with my meta-rig, how do I fix this?

I'm trying to rig my eyes, and make them follow the target that rigify automatically puts there, by parenting the eye ball to a mechanical bone. I made sure to place the bone in the correct place in ...
0
votes
0answers
14 views

Convert animation frames from JSON file

I have two different JSON files, first is for the Skeleton and the other for the Animation. I wrote a python script which converts the JSON skeleton values to a blender skeleton, and it seems to work ...
0
votes
1answer
39 views

Rotate all bones in rig by 90 degrees

I want to create an animation with a rigged model, but it appears as if the bones are all rotated 90 degrees: This is best visible in the tail; I would expect the tip of the left bones meet the head ...
0
votes
0answers
31 views

I cannot see the armature in any mode and I pressed all the H buttons

I am super new to blender. I made a person in MakeHuman and then imported it to blender. I made hair on it and then I went to add the armature and its not showing up. I can make one and see it in a ...
0
votes
1answer
21 views

Animations become messed up after rotating whole object. Is there an absolute (non-relative) posing mode or something?

(Beginner) I manually create keyframes with an option to include whole bone system of posed character. I wish to render animations of this character from 8 different angles, so I tried rotating it in ...
0
votes
1answer
12 views

Stretch To constraint with uniform scaling instead of stretching/deforming

This is not duplicate of questions where OP wants to know how to use stretch to as in these questions the OP is okay with the stretching behaviour that the constraint gives. I have two empties from ...
0
votes
1answer
18 views

amature problem

Im having problems trying to understand rigging and I keep getting this problem. Am I assigning to much on my body which is giving me this problem?
0
votes
1answer
22 views

Is it possible to animate a single mesh as if it were multiple objects?

I am attempting to animate a single mesh which appears as a group of separate objects. I want to animate three separate boxes which are joined together as a single mesh for ease of use in the dope ...

1
2 3 4 5
49