0
$\begingroup$

I've been trying to make Source model in blender completely animatable by using and modifying Source armature. I've Successfully imported it into Blender.

Right from the beginning I noticed that armature positions in edit mode and object modes are different. I thought that this wouldn't be a big problem since I wouldn't be using edit mode much.

When Trying to add additional bones as controlling bones for IKs and Pole targets, added bones would have correct position in the edit mode (in which I added the bones in) but wrong in object and pose mode.

I started trying various techniques to get armatures edit and object mode to match: I removed the armature modifier from the character model, applied physical geometry to mesh. Then in armature pose mode I applied pose as rest pose. Then I added back the armature modifier to the model object.

This seemingly worked fine as the bones and the mesh in the edit mode and object mode were having the same visible location. But when rendering, the final picture in the render was wrong. Even the rendered view in viewport was showing the correct position for everything, but in render, it appeared like I did nothing to fix the problem.

I discovered that it goes to wrong poses after render (or cancelling the render) and after opening saved file. I don't know what causes this.

By that time I had looked into numerous forums and everybody having the same problem had it because a modifier was turned off for render, but in my case the modifier was turned on.

Here is my .blend file for everyone to see. Since the problem comes back after opening the saved file, you won't be able to see what I did to fix it, but you can repeat my steps. Hope you get my point. Thank you in advance!

This is a file showcasing that the object mode and edit mode for mesh and armature aren't matching.

Here is total default file imported straight from CSGO, in case if you want to try something new.

$\endgroup$
2
$\begingroup$

The change in location during render or closing/opening the file is due to the animation, which is taken in account during render and opening the file.

The procedure for having your shoot as rest position for both the mesh and the armature is this:

Select the body mesh and apply the armature modifier. Do the same for the hands mesh. Select ALL bones in pose mode and apply pose as rest pose. Turn off the animation in the action editor. Add an armature modifier to the body mesh, choosing your skeleton as "object". Do the same for the hands mesh.

enter image description here

$\endgroup$
  • $\begingroup$ Thanks! I wouldn't ever have thought that an animation was causing that problem. $\endgroup$ – Kaarel Parve Feb 10 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.