2
$\begingroup$

I modeled a simple wall with a window using a cube and loop cuts. I also set the crease of each edge to 1.0. I intend to sculpt it now to get a rougher look. The problem is that when I add a subdivision level with the multiresolution modifier, I get a mesh with a highly varying vertex density.

before after

Is there any way I can subdivide it to get a base mesh with an even vertex density?

$\endgroup$
2
$\begingroup$

Add loop cuts to the larger parts of the wall ctrl R, so that the size in between the loops is about the same as the thickness of your wall. Then subdivide, if the base mesh has about the same size topology, then subdividing will yield same size topology.

loop cuts

$\endgroup$
2
$\begingroup$

You either need to have square faces before subdivision or use something such as the re-mesh modifier. I should note that the re mesh modifier will only work well on simple meshes such as the one you're working with. I would experiment with the Blocks mode as well as sharp, being aware the the Blocks mode will mess with the shape of your mesh.

$\endgroup$
  • $\begingroup$ Do you not like large images? You shrunk both the question's and my answer's images, why? $\endgroup$ – David Aug 9 '14 at 17:42
  • $\begingroup$ They can make stuff painful to read, as well as making the page very long. Also, for some people(with bad internet), they can make the page slow to load. $\endgroup$ – GiantCowFilms Aug 9 '14 at 18:47
  • $\begingroup$ @David You can remove the M from the end of the file name, and they will go back to normal size if you want. eg. imgur/examplem to imgur/example. $\endgroup$ – GiantCowFilms Aug 9 '14 at 18:48
1
$\begingroup$

I know this is old, but I'm going to necro this because I found a work-around. Be sure never to rescale (in part or in whole) your objects. Cut your objects to their general shape with boolean difference operations. This will maintain the uniformity of the mesh when you use the remesh modifier.

Example: Let's say you want a slab.

Ordinarily you would simply start with a cube and scale one dimension of the cube to the slab thickness. This, however, results in scaled mesh points. When you remesh this, it will remesh with squares on the unscaled sides and rectangles on the scaled sides.

Instead, start with a cube, but create a second, larger cube as well. Use the larger cube to cut the first cube into a slab using a boolean difference operation. Doing this will allow the remesh modifier to generate a uniform, square mesh on all sides regardless of the mesh size you choose.

Alternatively, you can begin with a plane and extrude it to the slab thickness. I've discovered that this kind of thing works too.

I don't know why Blender works this way, but it does.

Once again: My personal rule is to never scale an object until I am finished sculpting it. Every time I've violated this rule, I've suffered for it.

Here are some other tips I've found useful:

  1. When working with multiple objects, always remesh them to the same Octree Depth. If you don't your boolean operations could go wonky on you. Following this rule will also guarantee the most uniform mesh on your final object.

  2. Always remesh your objects immediately before you use them in boolean operations. Again inconsistencies in the mesh due to boolean or sculpting operations can cause unpredictable results.

  3. When remeshing, use the "Smooth" option if you have used brushes to sculpt your objects and you plan to use boolean operations on them later.

Unfortunately, once the quality of the mesh is compromised (e.g.: the object above) there's no way to "fix" it short of manually editing the mesh, in which case, you might as well just start over again.

Hope these help.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.