1
$\begingroup$

enter image description here

This happens everytime I merge some vertices and then apply the subdivision modifier. I've tried removing double vertices and even if I delete the edge that seems to be causing the problem this happens:

enter image description here

It just transfers to the next edge. Does someone know why it looks like it sticks to the original mesh? Any ideas on how to fix it are welcomed!

$\endgroup$
  • $\begingroup$ It doesn't sticks to original mesh, that's the subsurfed result. Likely the reason are internal faces, you could try to run Select > Select All By Trait > Internal Faces or select manually $\endgroup$ – Mr Zak Apr 11 at 9:50
  • $\begingroup$ didn't work :( they are pieces that were separated and I merged them vertex by vertex (the 4 corners) and that edge was the result, I don't know if maybe that's the issue... $\endgroup$ – Inés Gallego Martín Apr 11 at 9:58
  • $\begingroup$ You can provide the file using this link: blend-exchange.giantcowfilms.com $\endgroup$ – LeoNas Apr 11 at 10:57
  • $\begingroup$ I can't upload it, it says that "files may take some time to process" but nothing happens $\endgroup$ – Inés Gallego Martín Apr 11 at 11:18
  • $\begingroup$ I don't have any idea what's wrong exactly in your case and what were you merging to; the general principle is that Subsurf creates bulge like on the screenshot if you have: 1. internal face/-s 2. dobles. The can be created by other modifiers as well, depending on the case. In the blend-exchange.giantcowfilms.com site you're supposed to include link to the question and press Upload after choosing file, nothing is supposed to happen before that $\endgroup$ – Mr Zak Apr 11 at 16:34
1
$\begingroup$

Check if you have an internal quad, which is made with those edges. If there's a quad, delete it.

Also check the Mean Crease of those edges (1 means hard edge, 0 means soft edge):

enter image description here

$\endgroup$
  • $\begingroup$ there isn't and mean crease is at 0. This edge is the result of 4 merged vertices, I get something similar everytime I do that... $\endgroup$ – Inés Gallego Martín Apr 11 at 10:44
1
$\begingroup$

I may be very, very late to the party but as mentioned this was more than likely due to non-manifold geometry.

In Blender 2.80 I used the advice from an answer that I now cannot find to go to select>Select all by trait and then clicked all the options until I discovered some of my verts were non-manifold. The closest approximation to the answer lies here (it gives a shortcut for selecting non-manifold geometry instead).

In the end after discovering by tweaking the settings of the aforementioned select all by trait tool that some verts were non-contiguous I asked stack again for the answer and hey presto!, just recalculate internal normals.

N.B: this is what worked for me, but tools are linked to deal with identifying your non-manifold topology issue in many scenarios

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.