1
$\begingroup$

I'm sure this is an easy fix, but when I move the hand bones on my character, the bones move more than the mesh is moved. This happened to the feet as well but I move the bones to a different position and it fixed itself. I tried the same thing with the hands, but nothing seems to change.

Hand not moving with bone properly

Anyone got any ideas?

EDIT: I have already done weight painting, and the hand is completely red. Sorry for not mentioning this the begin with.

$\endgroup$
  • $\begingroup$ Did you check your vertex groups to see if the bone has proper weights? $\endgroup$ – Aoradon Jan 10 '18 at 0:51
  • $\begingroup$ Make sure that the hand vertices are only assigned to the one vertex group. If you select the hand vertices and go to the vertex groups panel, at the bottom right there is a dark arrow that opens a menu. Choose Remove From All Groups, then reassign the vertices to the hand group to see if that fixes it. $\endgroup$ – Brenticus Jan 10 '18 at 5:13
  • $\begingroup$ I think it needs more meshes. $\endgroup$ – LeoNas Jan 10 '18 at 16:30
  • $\begingroup$ @Whitest Glad I could help. I created an answer with this information. If you could accept the answer that will mark this question as solved. $\endgroup$ – Brenticus Jan 10 '18 at 16:48
1
$\begingroup$

Despite the fact that the hand is completely red, it is still most likely a weight painting issue.

A vertex on a mesh can be assigned to multiple different vertex groups which means it can be affected by multiple different bones. Since the hand mesh looks to be moving about half as much as it should, I think you have the vertices assigned to a second group as well.

You can manually select the bones in weight paint mode to see which one is causing the issue, but there is a quick way to solve this without even knowing which bone is the culprit.

In the vertex groups panel of the Object Data tab of the properties panel there is a small, dark arrow pointing down located on the right side (under the Plus and Minus icons). With your hand vertices selected, click on it to open a menu, and choose the Remove from All Groups option.

enter image description here

This will remove any and all vertex groups from these vertices. Then select the hand vertex group and assign a weight of 1 to your hand vertices and you should be good to go.

$\endgroup$
0
$\begingroup$

Its a weight paint problem you just need to select your bone in pose mode and then select your mesh and got to weight paint mode and then you just need to paint weight on the part of the mesh that is lagging behind and in your case increase the strength of your weight paint brush and paint it at the tip of that part. Point to remember: More the red your weight paint will be more sensitively it will react to your bone movement because red is the highest weight you can paint on your mesh to assign it to a bone.

You will also find lot's of tutorials online look for them if you do not understand.

$\endgroup$
  • $\begingroup$ sorry, I forgot to mention that I already did do weight painting, and the hand is completely red. This is still happening though. $\endgroup$ – Whitest Jan 10 '18 at 4:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.