2
$\begingroup$

I have a simple character with a rig, hands and feet are "rayman style". I don't want my mesh to be deformed so I have unchecked "deform" on all bones and IK bones.

When I parent with "armature deform - with automatic weights" the result is that it will not attach to the mesh.

I will provide the Blender file.

Can anyone guide me on how to do this without deforming the body?

Update #1: If I add "deform" on lower legs and lower arms, the armature will work as expected, but the feet and hands will be twisted in start position.

enter image description here

Update #2: weight painting both upper and lower legs (painting only the feet cubes red) and ticking deform on these will cause the feet to align correctly in start position, but will distort/shrink the mesh when moving the feet IK handle, see when knee bends in 2nd image (the desired result is to not deform anything).

enter image description here enter image description here

$\endgroup$
  • 1
    $\begingroup$ Hi. Please add images to illustrate your problem. While blend files are welcomed, they should be supplementary to good question content. In an ideal situation the question will have enough information that we don't have to download a file. $\endgroup$ – Ray Mairlot Feb 10 '18 at 17:39
  • $\begingroup$ Hi. Thank you for pointing out the importance of images, however I don't believe every type of request can be solved with an accurately stated question, it can most of the time though (ideally). This is more of an issue I don't really know what to do with, and one with more insight in rigging might have to open blender to see what's really going on or what settings might be causing the problem. $\endgroup$ – a22x Feb 10 '18 at 20:12
0
$\begingroup$

Your object is not weight painted. Blender needs to know which vertices are influenced by which bone. This is done by painting weights Basically you can do that two ways: 1 - Parent your mesh to your armature with automatic weights. You may have to tweak things as explained in point 2 though 2 - select a bone of your armature and go to weight paint mode to paint (red) the vertices influenced by that bone. Repeat for each bone.

Also make sure "deform" is ticked as shown on the picture, without which your bones will have no influence on your mesh.

enter image description here

$\endgroup$
  • $\begingroup$ That didn't seem to be the issue altough I thought so myself, I actually I did weight paint with the lower legs in the original file. I checked deformed on the the lower legs and tried again but I dont want the legs/feet to twist, I have updated the answer with a picture to resemble this. $\endgroup$ – a22x Feb 10 '18 at 18:13
  • $\begingroup$ I'm not sure what the problem is. I weight painted the legs in your example, ticked deform and everything is straight. $\endgroup$ – Kiskit Feb 10 '18 at 21:39
  • $\begingroup$ I did what you did, weight painted both upper and lower legs and the leg cube straights out, but try moving the feet IK handle, see update#2. weird. $\endgroup$ – a22x Feb 11 '18 at 9:30
0
$\begingroup$

So I found a solution to the problem.

I don't know much about the mechanics behind rigging a model, but I made a test where I splitted the whole mesh (body, hands, feet) into separate objects.

I then parented each object cube (hands/feet cubes) with the lowerArm/Leg bone using "set parent - bone" and weight painted the cubes all red with lowerArm/leg selected, then ticked "deform". (as opposed to earlier tests with "set parent - with automatic weights")

This gets the cubes to be aligned correctly in "pose position" and without distorting or shrinking the cubes when moving the IK handles.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.