0
$\begingroup$

i made an armature to my model (human), did all the parenting etc. i used empty weights and applied the weights to the vertex groups manually in edit mode because auto weighting didn't work out so well (the auto weighting is not there anymore. i made a new armature from a backup file w/o any armature work on it because i knew i would screw up eventually).

luckily, posing the bones causes only the selected vertexes to move, but not as quickly as i thought it would. an example on the hands: enter image description here

enter image description here

as you can see, the mesh doesnt follow the armature, though it is certainly influenced by it.

i have looked at the weight painting, it looks like this (assigning the vertex groups was all in edit mode; i didnt make any changes in weight painting mode): enter image description here

enter image description here

and these are the vertices (including front and back of the hand; used x-ray) i selected for the vertex group. pasteall file: https://pasteall.org/blend/0d726d4ea3994c59a574ad8fd836ccb9

thank you in advance :) -- edit: for moonboots -- enter image description here ive changed the weights for the forearm and the arm, but the mesh still doesnt yield: enter image description here

$\endgroup$
2
0
$\begingroup$

Select your armature, shift select the mesh, switch to Weight Paint mode, select the arm bones, you'll see that the hand is part of the vertex group that they are supposed to control, which should not be the case:

enter image description here

To correct that, you can either do it with a brush (set to Subtract), or in Edit mode, select the hand vertices, remove them from all groups, and reassign to the hand group only:

enter image description here

$\endgroup$
5
  • $\begingroup$ i used a brush to remove the vertices from the arms, but it seems nothing changed. i'll post images into the question again $\endgroup$ – leafmaster46 Mar 23 at 8:48
  • $\begingroup$ Yes because for some reason other bones, like Spine1 and Spine2 also influence it, so you need to correct this (make sure that the Front Face option is disabled in the brush > Advanced settings), and when it's done make sure that the hand bone affects the hand mesh (this tilme use Blend > Mix) $\endgroup$ – moonboots Mar 23 at 8:55
  • $\begingroup$ The second method, through the Vertex Group list, make things faster. $\endgroup$ – moonboots Mar 23 at 8:55
  • $\begingroup$ fixed it! i do wonder how the other bones ended up influencing it, since i started with an empty group? maybe i mirrored something incorrectly... either way thank you so much. $\endgroup$ – leafmaster46 Mar 23 at 9:16
  • $\begingroup$ Hard to say what happened ;) $\endgroup$ – moonboots Mar 23 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.