3
$\begingroup$

I have a sphere and stretched. I have made a curve and i want that curve to be shrinkwrap on it. I add the shrinkwrap modifier on to it but it lost the original shape. Its flat on the surface. enter image description here

How can i get the original shape without going flat on the surface. Any suggestion or help

$\endgroup$
4
$\begingroup$

The Shrinkwrap Modifier allows an object to "shrink" to the surface of another object. It moves each vertex of the object being modified to the closest position on the surface of the given mesh (using one of the three methods available).

from https://docs.blender.org/manual/ko/dev/modeling/modifiers/deform/shrinkwrap.html

So it's totally normal that it's looking like this.

You can use Vertex Groups:

The vertex group to control whether and how much each vertex is displaced to its target position. If a vertex is not a member of this group, it is not displaced (same as weight 0).

But in this case it will not help in any easy way. Maybe some detailed Weight Painting could do the trick though.

This is what you can do instead:

final

  1. Make Curve and convert it to a Mesh or just make this shape by Extruding single vertex. In this case second option would be faster.
  2. Add to it Shrinkwrap modifier.
  3. Add Skin modifier. Turn off Symmetry X Axis and check Smooth Shading.
  4. Add Subdivision Surface modifier.
  5. Go to Edit Mode and select first and last vertex.
  6. With Proportional Editing turned on and fallof set to Sphere hit Ctrl+A and scale both vertices as you want.

This is whole setup:

setup

| improve this answer | |
$\endgroup$
  • $\begingroup$ The result is perfect. $\endgroup$ – atek Sep 1 '17 at 6:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.