1
$\begingroup$

I have a subdivided mesh. I have added shrinkwrap modifier to it. Before adding shrinkwrap modifier its has a solid thickness but after adding the shrinkwrap modifier the thickness disappear. I have tried all options but its working. When it is shrink its perfect but no extrude or thickness to the mesh. Any suggestion or help.

enter image description here

$\endgroup$
  • $\begingroup$ Is your older question the same thing, or is this different? $\endgroup$ – David Dec 7 '17 at 3:23
  • $\begingroup$ @RayMairlot. I have other mesh beside this original. I have copied the 1st mesh and made this mesh. It is perfect but why problem with this mesh. $\endgroup$ – atek Dec 7 '17 at 3:40
  • $\begingroup$ @David the older and new question are different. I have other mesh beside this original. I have copied the 1st mesh and made this mesh. It is perfect but why problem with this mesh $\endgroup$ – atek Dec 7 '17 at 3:41
  • $\begingroup$ @Atek the mirror modifier will flatten your mesh (as explained to you on your previous question) As an alternative you can try using a lattice to deform the mesh and have the lattice use the swhinkwrap like this: blender.stackexchange.com/questions/44758/… or blender.stackexchange.com/questions/48823/… $\endgroup$ – user1853 Dec 7 '17 at 11:15
2
$\begingroup$

The shrinkwrap modifier will flatten your mesh (as explained to you on your previous question) since it will move all vertices onto the target mesh.

As an alternative you can try using a lattice to deform the mesh and have the lattice use the swhinkwrap. As the lattice is deformed your mesh will undertake a similar deformation.

Create a lattice with only one subdivision on the vertical axis. This is achieved via the Lattice properties in the properties panel (only visible when the lattice is selected - see the right-hand side of the image below). The Lattice properties define the number of U, V, W dimensions of the lattice. The dimensions default to 2, 2, 2 - effectively forming a cube. By increasing the dimensions in two directions (to give us some subdivisions) and setting the other dimension to 1 will form a plane. When the plane is deformed this can be used to affect your mesh - but since the lattice plane has no 'height' it also will not affect the 'height' of your mesh. Position the lattice along the baseline of the mesh you want to deform.

enter image description here

Add a lattice deform modifier to the design that you want to bend, and select the lattice object as the one to deform the mesh.

enter image description here

Now simply add a Shrinkwrap modifier to the lattice with the Target set to the surface you want to deform to. The lattice should now be deformed to the surface and your mesh will be deformed similarly. Adjust the Shrinkwrap distance and settings to fine-tune.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for the answer but i did not get. Do u mean that i have to add lattice in edit mode of the design or how to add the lattice. Can u plz attach the file so that i can go through $\endgroup$ – atek Dec 7 '17 at 12:50
  • $\begingroup$ A lattice is a separate object. In edit mode do Add>Lattice $\endgroup$ – user1853 Dec 7 '17 at 15:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.