4
$\begingroup$

I have a bunch of dominos set up in my scene. I want them to tip each other over(aka the domino effect). However, they're not falling realistically. They're falling way to slow.

My dominos are reshaped cubes, which I've applied a box-type rigid body to. But because of limitations unbeknowst to me, I can't properly use rigid body on so small objects. Therefore I've scaled them up to 40 times larger. They are now 81,284cm x 25,414cm x 177,8cm. Because they are sooooooo large, they fall reaaaaally slow.

They are standing on a plane which have been applied a passive rigidbody.

Is there any way of making them fall realistically fast?

I've tested speeding up the scene time, but turns out a bit weird/unrealistic. I've tested bumping up the gravity, but also feels a bit weird.

File: http://www.pasteall.org/blend/26893

$\endgroup$
  • $\begingroup$ It's true that rigid body systems needs the object demension to be relatively large. Would you upload the file download link here? You can upload via PasteAll.org $\endgroup$ – Leon Cheung Feb 17 '14 at 11:49
  • $\begingroup$ Put link in post. $\endgroup$ – FragmentAlteration Feb 17 '14 at 12:03
3
$\begingroup$

Normally, when simulating for the first time after adjustment, the data needs to be cached. It will look more smoother as expected when playing back from then on.

If this is not the case here, then you can adjust the Speed value located in Rigid Body Worlds panel, which lets you control the speed factor for simulation.

enter image description here

$\endgroup$
  • $\begingroup$ Thx. I'm aware of the caching for first time simulations. I've also tested upping the speed, but it doesn't get a realistic feel to it. You can kinda tell it's been speed up, which ruins the captivation of the viewer. $\endgroup$ – FragmentAlteration Feb 17 '14 at 12:23
  • $\begingroup$ Even multiplying the speed with 40(the same multiplier I've used on the scale) doesn't cut it. Still feels weird. $\endgroup$ – FragmentAlteration Feb 17 '14 at 12:24
  • $\begingroup$ @FragmentAlteration Aftering further tweaking with your file. I've managed to use small size and mass for the simulation. See here, FYI. $\endgroup$ – Leon Cheung Feb 17 '14 at 12:48
  • $\begingroup$ That's amazing. Thx. What did you change to make it work? $\endgroup$ – FragmentAlteration Feb 17 '14 at 12:55
  • $\begingroup$ @FragmentAlteration It seems you cannot go to the chatroom here yet. In short, with small sized objects, I think you need to nake the Passive object solid, in order to let the collision shapes to work well. $\endgroup$ – Leon Cheung Feb 17 '14 at 13:01
2
$\begingroup$

I have gotten much better results (even with tiny objects) by using Box as the collision shape for the floor.

It's generally good practice to use manifold objects and primitive collision shapes wherever possible.

enter image description here

Example file

$\endgroup$
0
$\begingroup$

You can fix this by modelling it in real world sizes. Though, as Blender's physics simulation doesn't work properly with small items, this needs some setting up.

  • Go to the Scene tab in the Properties area, as shown in the image below.
  • Set units to metric and scale to 0.01. When you enter a size somewhere without a unit, this will be interpreted as centimetres.
  • Until bug T52238 is fixed, set gravity to -981.
  • To prevent jittering and objects falling through each other, you need to set Steps Per Second a lot higher, for example 300.

In the Properties area under Scene tab, the Units scale, Gravity and Rigid body world's Steps Per Second are marked.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.