6
$\begingroup$

I am making this scene of a bowl of chips in a bowl and I am trying the use rigid body physics to place them in the bowl in a realistic fashion.

There are two ways I have been trying to achieve this:

  1. Simulating all the chips falling at once.

When I try is this the chips fall down and collide with the bowl just fine but then will not stop jigging bouncing and catapulting out and and thru the bowl.

  1. Dropping the rigid bodies in one at a time.

This seems the prevent the jigging and clipping issues but I can't find a way to switch the individual rigid body back to a normal mesh without the timeline resetting thus preventing me from simulating the rest. (I suspected if the turn the physics off for each chip after they stopped moving would prevent the next chip violently reacting with it).

Any ideas on how to get the damn things into the bowl and then turn them back the normal meshes?

enter image description here

Mesh collision box deform base.

I looked at other tutorials but nothing helped, I just dont know what the problem is.

$\endgroup$
4
$\begingroup$

The solution is quite simple! you need to enable deactivation on the chip meshes.

enter image description here

If they don't settle down fast enough, raise the linear and angular velocities. I'd especially recommenced the angular velocity (amount of rotation).

How this option works is that when the rigid body gets still enough, it is deactivated and stops moving.

For you particular simulation, values around 2.6 seemed to work well.

Here is a working .blend

$\endgroup$
  • $\begingroup$ didn't work. they still end up leaving the bowl. probably should have mention that the meshes keep clipping into each other, maybe that had something to do with it?. did it work for you? can you show a picture of the successful result? $\endgroup$ – a million little polygons Sep 15 '15 at 15:41
  • $\begingroup$ @amillionlittlepolygons Here: i.stack.imgur.com/Cznxc.gif $\endgroup$ – GiantCowFilms Sep 15 '15 at 15:51
  • $\begingroup$ @amillionlittlepolygons Higher FPS: gfycat.com/UnhappyRealHind $\endgroup$ – GiantCowFilms Sep 15 '15 at 16:16
  • $\begingroup$ they still clip into eachother which is just about the last thing i want. anything than can be done about than? $\endgroup$ – a million little polygons Sep 16 '15 at 10:42
  • 1
    $\begingroup$ @amillionlittlepolygons You will need to increase the simulation quality in the properties panel then; however, I will note it is virtually impossible to get a perfectly clean simulation. $\endgroup$ – GiantCowFilms Sep 16 '15 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.