0
$\begingroup$

I am designing a Galton Board, so I have a group of marbles, which are active rigid bodies, and then I also have a bunch of rectangles, which the balls are supposed to hit and then veer off.

And while this does happen to most of the balls, some of them either enter one of the rectangles on impact, or make it to the very bottom and fall through the floor.

Here I have an image of one of the frames:

Some of the balls pass through other passive rigid bodies

The small rectangles represent the things off off which the balls are supposed bounce, and the tiny congested spheres represent the marbles. The panel on the right displays the physics settings for the balls.

As you can see, some of the balls are falling through the floor; while others have entered the rectangles.

And now here I have an image of the physics for everything else:

The Physics settings for everything else.

Extra Notes/Details: All of the marbles share the same Physics, every other object shares the same physics (they are passive & different from the marbles' physics), the scale of every single object is applied, and also that all of the objects except the marbles have a solidify modifier applied to them.

Blender Version: 2.79b, although I'm sure that this problem can be reproduced in Blender 2.8 as well.

Thanks.

$\endgroup$
0
$\begingroup$

Try to compose the collision of simpler collision shapes like spheres and cubes. Mesh collisions are expensive and unreliable. You can also try to increase the Rigid Body World to have more Steps Per Second. Sometimes you need to remove and recreate the Rigid Body on the problematic objects.

$\endgroup$
0
$\begingroup$

If the passive rigid body is animated then don't forget to turn on Animated in the passive rigid body settings or else the active bodies will not collide.

$\endgroup$
0
$\begingroup$
  1. While all the answers point out some reasonable things, i believe that it's most likely that the Rigid Body Collision Source" needs to be set to "Final" so all modifiers are included in the calculation, as OP mentioned all but the marble have modifiers to them.
  2. Also mentioned as try to from @Jackdaw, the Rigid Body World settings, especially the "Steps Per Second" and "Solver Iterations" do have a lot influence here, as the marbles will be in some cases too fast, before eventually hitting an object they are supposed to collide with. In that case they may pass just through as the iterations do not catch the intersection of the 2 objects. Increasing these settings should help, but will cost more calculation time.
  3. In simple situations you can replace the small objects with thicker placeholders for the physics, sadly here it would not work so easy as there are just too many of the small /thin objects and they are very close to each other. So most probably increasing the iterations and step number mighty be the only solution here.
  4. While you can't do it with the rectangles along the way of the marbles, you can use a placeholder bottom with more thickness invisible for render to make sure the marbles won't fall through the bottom. Just overlap a thick bottom with the current one aligned at the top and use the physics on that one, turn of visibility in render and use the original just for the visual part.

And yes, the problem should be independent of the version, especially with this close of release versions. It's more of a can blenders physics calculation catch if there is a collision problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.