0
$\begingroup$

I am new to using physics simulations in Blender, and I am having trouble setting up a rigid body physics with an armature deformed mesh in the scene. Basically, I have an animated mesh of a fridge spewing groceries on the floor, except without the groceries at the moment. I want these objects to begin inside the fridge since there is a hollow space inside it, and stay in there until the fridge door is opened later in the animation.

falls through inside collision is not accurate

Currently, it seems the active rigid body objects don't interact correctly, or at all, with the fridge which is set as a passive rigid body. All the objects are set as Mesh for their shapes.

I have included pictures of the settings I currently have for both the animated fridge, and a grocery object. All the groceries have the same settings, except for mass.

Grocery settings Fridge settings

I have messed around with a whole lot of settings in the physics tabs for the objects, but I honestly dont know what I am doing.

If you know any solutions to my problem, please let me know!

$\endgroup$
0
$\begingroup$

For Fridge (Passive) enable Animated. If Groceries didn't stay inside on Fridge move it can be because Fridge moves too fast, and some subsets would be needed for simulation - Scene Properties > Riggid Body World > Steps Per Second - increase value.

enter image description here

Note: Second gif looks like you have a hidden Cube with Passive Riggid Body in a Scene.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Thank you for your answer! I solved this with a combination of what you said, and a few other blender hacky solutions that worked for what I was trying to achieve. The fridge was simply moving too fast for any simulation to accurately take place, so i made a fake invisible fridge, which i keyframed to be visible when i needed it to be, while i completely disabled the original fridges physics. I also found that setting the objects collision shape to convex hull really helped stop the objects bouncing around too much. $\endgroup$ – Theb_Deluxe Mar 12 at 4:01
  • $\begingroup$ Great. I noticed there is an edge where steps per sec are not enough, and only slowdown animation helped. You could also start sim groceries on frame where fridge stops and open door. BTW would be really helpful if you would provide summarised (working) answer, so others can solve similar issue from your answer. Thank you . I will delete my answer $\endgroup$ – vklidu Mar 12 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.