0
$\begingroup$

I recently started work on a sword hilt to which I was later going to add a different blade and handle style to, however as i modeled this mesh flat and from a single vertex extruded to reduce the challenge to myself of connecting individual meshes together correctly i got the shape mostly correct however i cannot create the smoothed/curved effect that can be seen in the following image in the indicated areas that lead into the sharper edges.

The arrows on the top image indicate the areas where the plastic or metal material curves into a sharp edge (the bottom arrow) and a flat side touching the blade (the top arrow)

the second image is an angle view of the mesh as it is currently, i have tested with marking shapr edges and smooth shading, and even the smooth modifier but they both resulted in a glitched out mesh that doesnt hold its shape at all even at sharp areas.enter image description hereenter image description here

$\endgroup$
  • $\begingroup$ What you are looking for is the bevel modifier, see This: blender.stackexchange.com/questions/247/… $\endgroup$ – tacofisher Nov 21 '16 at 1:06
  • $\begingroup$ the bevel modifier i have used before and it doesnt have the ability to do it as far as i can tell, it makes edges pretty well but to make a smooth effect for the specified areas it doesnt really work, niether do the shading or smooth modifiers $\endgroup$ – Flamesofshadow Nov 21 '16 at 1:08
  • $\begingroup$ I dont wan't to post an answer because I don't really understand what you are trying to correct in your model. But If you are trying to create curves in specific areas of the object, then search for proportinal editing, that might help. $\endgroup$ – tacofisher Nov 21 '16 at 1:28
  • $\begingroup$ in the first image which i had to re add because it messed up twce for some reason, you can see the arrows which are pointing at hte areas where the mesh goes from flat to a smooth curve, the bottom one which is on the spear tip type side piece has a sharp blade like edge which curves gently untill it gets to the other side of the blade while the triangle part which sticks out of those middle pieces is also slightly angled. the top arrow points to the roundish part which goes flat at the blade so it can fit against it but the curve is the part my mesh doesnt have. prop editing didnt work $\endgroup$ – Flamesofshadow Nov 21 '16 at 1:38
  • $\begingroup$ Within the Bevel modifier you are able to set it to make multiple cuts on an edge. Try turning on the object's wireframe on mesh display to see everything its doing. You may have to turn off clamp and adjust its size. A subsurf modifier may also be necessary after the bevel. $\endgroup$ – Drudge Nov 21 '16 at 1:54
0
$\begingroup$

with further testing all day i found the only thing that will work even slightly is adding vertexes at angles as close as possible, no form of smoothing can be done however which is unfortunate but seems to be the best way. mainly the vertexes were needed to be scaled on the z axis just above the others with faces created from it in all the areas i needed it

$\endgroup$
  • $\begingroup$ To be honest I can't understand this answer. The problem probably is in topology of the mesh and yes, Bevel is one of solutions for the final result. $\endgroup$ – Mr Zak Feb 8 '17 at 10:32
0
$\begingroup$

One solution is to select the edges you want and hit Ctrl-B. Then use the mouse wheel to add the level of curvature you want.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.