This question already has an answer here:

I have the latest version of Blender installed (2.69) on Debian stable, and in System Preferences there is no CUDA (GPU) option for compute device. The graphics card is Nvidia GeForce 430. It supports CUDA 2.1, so according to the wiki it should work. Looks like the Nvidia driver is at the newest version. Is it a bug or am I missing something?

Update: Still no answer. I've looked into the driver more: it's the most recent repository version, but the driver on the Nvidia website is newer (mine is 304.88, theirs is 331.38). Does anybody run Blender on Linux with Nvidia drivers from repository (not nouveau but the manufacturer drivers)?

Anna

P.S. I've seen a couple other threads with a similar question but in one the problem was resolved when Blender v.2.69 was installed and in another the card in question was explicitly among the ones no longer supported.

marked as duplicate by gandalf3, CharlesL, Vader, David, Ray Mairlot Apr 12 '14 at 14:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • It sounds like this could be a bug report, which is off-topic for this SE, but I recognize that you're probably asking "is this a bug, or am I missing something?" Clarifying your question might eliminate the close votes. – Matt Jan 13 '14 at 22:05
  • 1
    Do you have CUDA installed properly? You can download it from here if you haven't already: developer.nvidia.com/cuda-downloads – CharlesL Jan 13 '14 at 22:08
  • @Matt: Thanks! Exactly what I was thinking. – seadeer Jan 13 '14 at 22:15
  • 1
    Hmm... I needed to install it to make it show up (at least in Blender 2.61), and I don't see anything in the wiki that says that it's included in the binary. – CharlesL Jan 13 '14 at 23:51
  • 1
    I had a similar problem on ubuntu. Once I installed the latest stable proprietary driver it worked. – Vader Feb 18 '14 at 20:05

IT IS the driver! The Nvidia driver installed from repositories on Debian is old. I've installed the newest driver by using sgfxi (see manual here). Just shut down the X-server, ran the script without any options (for this graphics card you don't need to enable the compositing option, it is enabled by default), it installed without a glitch. And halleluja! - GPU option appeared in Blender.

I found out that if I download and extract the new blender version for linux and execute this version then CUDA is supported. BUT it I start the installed blender version CUDA does not work.

I once installed the toolkit but since I know the workaround I just download the newest blender version from blender.org and use this one.

My OS: Kubuntu 12.04

Have fun!

Not the answer you're looking for? Browse other questions tagged or ask your own question.