1
$\begingroup$

I am struggling for a week now, trying my blender to work with CUDA GPU Cyclea Rendering, did so many fresh installation, still no luck.

Current situation:

Fresh install of Blender 2.69 (from repository ) Installed Nvidia GeForce GT 640 driver from official website using text base terminal. Installed CUDA 5.5 from official website using text base terminal.

My system:
Intel core i7, nvidia 640, OS ubuntu 12.04 64bit.

What I want to achieve:
I Want to run blender with CUDA GPU cycles rendering.
I also want to run some program which requires 32bit lib installed.

Current Problem:

  1. Blender works fine, I can see the CUDA option but when I try to render using Cycles GPU render it does not work, no rendered image is produced.
  2. Other program which needs 32bit lib does not work, it says it requires 32 bit lib, when I try to install that 32 bit lib it says its already there.

any help will be highly appreciated. thanks.

$\endgroup$
  • $\begingroup$ Does blender give any errors? Try running blender from the terminal. $\endgroup$ – gandalf3 Nov 26 '13 at 9:36
  • $\begingroup$ yes,shams@ubuntu:~$ blender connect failed: No such file or directory Read new prefs: /home/shams/.config/blender/2.69/config/userpref.blend CUDA version 5.5 detected, build may succeed but only CUDA 5.0 is officially supported. Compiling CUDA kernel ... "/usr/local/cuda/bin/nvcc" -arch=sm_30 -m64 --cubin $\endgroup$ – shams Nov 26 '13 at 10:04
  • $\begingroup$ "/usr/share/blender/2.69/scripts/addons/cycles/kernel/kernel.cu" -o "/home/shams/.config/blender/2.69/cache/cycles_kernel_sm30_96A6C0A49E419B95313AA9C5576B6320.cubin" --ptxas-options="-v" --maxrregcount=32 --use_fast_math -I"/usr/share/blender/2.69/scripts/addons/cycles/kernel" -DNVCC -D__KERNEL_CUDA_VERSION__=55 gcc: error trying to exec 'cc1plus': execvp: No such file or directory CUDA kernel compilation failed, see console for details. Refer to the Cycles GPU rendering documentation for possible solutions: wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/… $\endgroup$ – shams Nov 26 '13 at 10:38
  • 1
    $\begingroup$ It looks like you are using CUDA 5.5, and only 5.0 is supported. Try installing CUDA 5.0. (I found this guide from a quick google search) $\endgroup$ – gandalf3 Nov 26 '13 at 10:46
  • 1
    $\begingroup$ We can't help you with the "other program" here, since that is outside the scope of our site. $\endgroup$ – A Wild RolandiXor Nov 26 '13 at 16:45
3
$\begingroup$

I had also such a problem and solved it by deselecting WITH_CYCLES_CUDA_BINARIES in cmake(-gui).

Without this blender will compile the correct .cubin file when you first try to render with the GPU. This will take a while (a few minutes on my i7), but it works.

To solve the problem with 32-bit you probably need to install glibc-devel-32bit (or similar, so called on openSUSE). There was some error about missing a header out of this while compiling blender.

$\endgroup$
  • $\begingroup$ @shams: GPU rendering can be longer than CPU rendering. With my GT650 on windows 8 the GPU is a little bit faster and on OpenSuse the CPU is a bit faster. $\endgroup$ – TobiMarg Dec 26 '13 at 10:54
0
$\begingroup$

To solve the problem with 32-bit you probably need to install glibc-devel-32bit (or similar, so called on openSUSE)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.