This question already has an answer here:

I am using Blender 2.66a a nVidia GT 520 and Ubuntu 13.10. I wanted to enable GPU rendering. But in the System Panel there is no 'CUDA' Option.
I know that this Card supports CUDA, because I have tested it on Windows 7 (dual- boot) too and it worked.
I installed the proprietary GPU driver using

sudo apt-get install nvidia-current

Any ideas why it doesnt work?
Thanks in the preface

marked as duplicate by Vader, CharlesL, Keavon, Gunslinger, iKlsR Mar 5 '14 at 17:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Is there any particular reason you are using that version of Blender? – gandalf3 Jan 2 '14 at 22:15
  • 1
    Yes, its the latest Version, thats available in the official repository! – Peter Parker Jan 3 '14 at 14:11
  • 1
    I have tried it using the latest Version (2.69) and it worked, but GPU rendering takes more time and CPU rendering. Do I need to adjust some settings ? – Peter Parker Jan 3 '14 at 14:22
  • 1
    It's really odd that GPU would take longer than CPU. If you're on a laptop, it's entirely possible that Blender is mistakenly using your onboard graphics, rather than your nVidia card. Also keep in mind that you have to select which card to use in the User Preferences, as well as choosing GPU rather than CPU in the Render panel. It'd be nice if these two settings would affect each other, or at least provide a warning, but they didn't the last time I made this mistake. – Matt Jan 3 '14 at 17:52
  • 1
    @Peter Parker That's really.... REALLY odd. It's easier for me to believe that you have a really strange scene, than to believe CPU is actually faster than GPU, IWC yes, I do believe there's a way to speed it up, I just don't know what it is. I'd love to take a look at the scene you're rendering and see if it fits one of the strange cases I've come across. – Matt Jan 5 '14 at 16:06

I agree with @Matt, especially if you are on a laptop. Whether you are on a laptop or a desktop PC, I would check the following settings in Blender. Also, when using GPU rendering in Cycles, make sure to check the settings in the Properties tab -> Performance -> Tiles. By default the two numbers under the "Tiles" settings usually are 64 x 64 (pixels). If you are able to get your Nvidia GT 520 video card to work, try bumping up those numbers to 200 x 80 and see if that helps. The other thing i recommend checking is the "Sampling" menu in the Properties panel. If the final render has a high sample number (i.e. - 800 or above), that can also cause render time to be slow. enter image description here

CUDA level support is different between GPUs, see this link. Higher CUDA compliance results in better speedup. As I remember, Blender needs at least CUDA 2.0 features, but higher level of CUDA compliance is better.

Earlier Blenders did not even allow using CUDA below 2.0.

It seems that your GPU is CUDA 2.1 compliant, check if your CUDA driver is the latest, too. My guess is that your driver shows a supported version < 2.0 to Blender 2.66a, and so Blender 2.66a did not show CUDA support.

Also, others' comment about optimizations are also very valid.

Not the answer you're looking for? Browse other questions tagged or ask your own question.