I know there are a lot of threads concerning CUDA and GPU-rendering in Blender, but I haven't figured out yet why my installed Blender(2.70) from the repository offers no choice of the rendering-hardware but the bundle you get from blender.org does?

I'm currently using Linux Mint 16 64bit but I observed that fact on Ubuntu 12.04 as well. But on Ubuntu 14.04 the CUDA-option is active on both versions of Blender.

So my system has the necessary drivers to go on with the GPU, the question is, where do I start to fix the repository version, cause I'd like to link the blend-files..

  • $\begingroup$ It's possible the package maintainers simply aren't building with CUDA enabled.. If the blender.org version works, is there reason you can't use that? $\endgroup$
    – gandalf3
    Apr 29, 2014 at 22:17
  • $\begingroup$ I had that same issue (and others) when installing 2.7 form repository on Linux Mint 16. The blender.org/download works fine. $\endgroup$
    – user1853
    Apr 29, 2014 at 23:56
  • $\begingroup$ @gandalf3: As I mentioned in the last paragraph, I don't know how to link files to not installed programmes like the bundle from blender.org. To open a programm, then selecting files isn't my typical workflow...^^ $\endgroup$
    – user3328
    May 1, 2014 at 16:22
  • $\begingroup$ Using most file managers you should be able to right click and define a path to an executable to open any files of that type. However "how to specify what program opens a file in x filemanager" isn't really related to blender anymore.. You might try on askubuntu $\endgroup$
    – gandalf3
    May 1, 2014 at 18:12

1 Answer 1


I've just made an install of Linux Mint 16 64bit (with the Mate window manager) and have Blender3D working with CUDA.

Here is what did:
1: After installation of Linux Mint 16 64bit I did an update (many files)
2: Reboot.
3: Enabled the proprietary Nvidia-driver
4: With the Software Manager I installed the CUDA Toolkit (nvidia-cuda-toolkit)
5: Reboot.
6: Install Blender 3D
7: In Blender 3D CUDA was now available.

I'm not sure if nr.4 and nr.6 can be switched ... but you can try.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .