Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now

Questions tagged [linux]

Questions pertaining to the Linux Operating System as it relates to Blender. Questions can be anything from compatibility to optimization to making Blender work on a specific distro.

Filter by
Sorted by
Tagged with
1
vote
1answer
27 views

Having trouble getting 2.80 on Linux

I just installed Blender and noticed my screen looked a little different from the tutorial video, so I checked my version and the Linux discovery page had grabbed me 2.79... Okay, so I tried ...
0
votes
0answers
17 views

Ubuntu Blender 2.8 wont detect Nvidia GPU

I have re installed drivers twice, and re installed blender, watched a couple of tutorials but i cant seem to get the option to select my GPU in CUDA >n< ,it is a 1050 mobile, im testing ubuntu on ...
0
votes
0answers
15 views

How to config Blender on Ubuntu 18 to use Amd-pro-gpu Driver instead of ROCM?

I run blender on ubuntu 18.04. After setting up the system and installing the AMD-pro-gpu driver for my VEGA FE from AMD' s official website, blender performed smoothly completing the BMW demo (gpu ...
1
vote
1answer
44 views

Where do I put the Blender folder on linux?

It might be a silly question: where do I have to put the folder extracted from .tar.bz2 in a linux machine (Debian)? Usually I use a repository to install it but with the experimental versions I never ...
1
vote
2answers
99 views

Enabling OpenCL GPU rendering for Cycles on Linux?

I followed the answer on this question for blender 2.7x, but I still don't see the option to enable GPU rendering for cycles, as shown in this screenshot: I'm using an RX 560 on Debian 11 ...
1
vote
0answers
18 views

User Preferences File Not Compatible Between Win and Linux

I'm using both Windows and Linux and I was hoping to be able to sync the userpref.blend between these operating systems but it seems it doesn't work. I've tried with both Blender Sync and by manually ...
0
votes
0answers
55 views

Headless Linux with 2.80: Cycles/CUDA GPU no longer used

I use a headless Xubuntu Server 18.04.3 with two GTX 970 cards as a render farm. This has worked with Blender up to 2.79 but is now broken in 2.80. Basic command to that used to work: ...
0
votes
0answers
80 views

Failure enabling Radeon ProRender in Blender 2.80 on Ubuntu 18.04

[Edit: It is suspected that the failure is caused by the fact that the .run file is built for ubuntu 16 but the actual os is ubuntu 18. However the version built for ubuntu 18.04 cannot be found ...
0
votes
0answers
46 views

Q: Blender 2.8 desktop shortcut doesn't work

After downloading 2.8 on Linux Mint, the blender.desktop shortcut doesn't open the application; it simply displays "There was an error launching the application". ...
0
votes
1answer
39 views

Blender doesnt start up

Installed linux mint on my macbook pro (13 inch 2010 model) When I run blender from my terminal this is what it outputs ...
0
votes
0answers
19 views

How to install blender 2.79 -on-centos-7 DEDICATED SERVER? (CentOS Linux release 7.6.1810 (Core)

Only need to use blender to render in the background via .py script, GUI not needed. This video is why I think it will work, published on Jun 27, 2019: https://www.youtube.com/watch?v=LbadAU8CULs (...
0
votes
0answers
75 views

Blender 2.8 UI defects on Linux Mint 19, AMD Radeon HD 4000 (but works well on Windows on same machine)

the latest mesa driver in use, but the UI is broken as shown below This happens only on Linux Mint 19.1 and not on Windows (On the very same machine) I know, GPU is not supported by Blender 2.8 but ...
1
vote
0answers
59 views

Crashes with backtrace in Ubuntu after few minutes of use

Blender 2.8 keeps crashing after a bit of use within Ubuntu 18.04 Desktop. I've run Blender from command-line which on start-up returned this (may not be of much use): ...
2
votes
1answer
90 views

Blender on remote Linux machine via X server

I am trying to get Blender to start on a remote machine via an X11 session. I have tried this in the past (circa Blender 2.6 ~ 2.69) and it has worked without problems. The Linux machine (VM Running ...
1
vote
1answer
37 views

How to start rendering (and save result) in terminal on Ubuntu?

I am getting ready, to try out cloud computing for Blender rendering, that's why I'm curious if I can just drop the .blend file and render the scene from the terminal. PS: Can Somebody tell me if I ...
1
vote
0answers
56 views

Segfault on 2.8 when switching to Cycles rendered viewport using bumblebee [closed]

Some infos on my system: CPU: i5-4210U GPU: NVIDIA 840M OS: Debian 10 stable OpenGL version string: 4.6.0 NVIDIA 418.74 This started to happen when I upgraded from Debian 9 to 10. When I start ...
0
votes
1answer
88 views

blender 2.80 linux executable crashing

I downloaded fresh Blender 2.80 for Linux64, but it is crashing on my Debian Linux (with Nvidia card), see below. Any help, please ? ...
2
votes
0answers
31 views

Segmentation fault (core dumped) on closest_point_on_mesh call in Ubuntu [closed]

I triangulate an object and then call obj.closest_point_on_mesh call(). The call doesn't finish and my blender crashes. This happens only in Ubuntu, I also tried my ...
0
votes
1answer
164 views

No lights rendered in Eevee

I'm very new to Blender and tried Blender 2.8. My currently problem is that Eevee does not render the lights I placed in the scene as shown below: The final render of Eevee: The weird thing is that ...
0
votes
0answers
18 views

Active GPU in Terminal Linux [duplicate]

I'm trying to test the Google Cloud Platform to render Blender projects. To make this, I created a Virtual Machine in GCP with Ubuntu 19 OS and, using a SSH conection, I did install Blender 2.8. I ...
2
votes
2answers
186 views

Do “make install” on different Linux sytem than the one used for “make bpy”

I have successfully built Blender-2.80-Beta as bpy (as in make bpy) for linux in Ubuntu 18. Also when i do make install on the ...
3
votes
2answers
537 views

Unable to run Blender 2.8 beta on Raspbian Buster

I recently bought a Raspberry Pi 4 (4GB). I wanted to test Blender 2.8 on it, but I am unable to get it running. If I install the 2.79 stable version from the app store or terminal, it works ...
0
votes
0answers
87 views

Resource for Blender-2.80 python-module for Linux

While i successfully built the blender-2.80 python module on Windows (without changing anything), i have great difficulty building it for linux (at least in Ubuntu). Is there anywhere where i can ...
0
votes
1answer
96 views

Building Blender from source with static linking [closed]

I'm following these instructions to build Blender from source as a Python module. As I need to share my build with others in a different runtime environment, I need to build it with static linking. I ...
0
votes
0answers
24 views

Is it possible to produce animations with Blender on DigitalOcean?

I am trying to produce an mp4 animation with the following command within a DigitalOcean droplet. ...
0
votes
0answers
176 views

Can a Raspberry Pi GPU be used with Cycles?

I have a Raspberry Pi 2 and a 3, both of which have separate GPUs from the CPU. They are running the default Raspbian (9 I think), and Blender (slightly out-of-daste repository version) is ...
0
votes
1answer
338 views

Blender 2.8 Beta (Linux Mint 19.1): No compatible GPUs found - Vega 64 Nitro+

I can't find any working information, how to fix this, and before I was trying to install some other drivers for my Vega, but i accidentally broke my previous installation.
0
votes
1answer
40 views

Can't Convert to Curve|Mesh using ALT+C in linux [duplicate]

In Blender 2.79 and 2.80 on os Linux the command ALT+C (Convert to Curve|Mesh) does not work: pressing the keys does not cause any results. Note that in the preferences the shortcut is correctly set. ...
0
votes
0answers
39 views

Renders with Fresnel, ColorMap, and Toon BSDF don't look right

I'm spanking new to Blender (as in < 1 day), so this may be a false alarm, but a simple object with Fresnel/ColorMap/Toon BSDF is rendering black with Eevee. Even the Cycles render doesn't look ...
1
vote
1answer
60 views

Change modifier key from Alt to Super/windows key

I'm running Blender on a fairly customized linux distribution and Alt is already taken by another program. I therefore wonder if there's an easy way to change to modifier key Alt to Super key globally?...
4
votes
1answer
175 views

How to make use of custom external Python modules in Blender or an add-on on Linux [duplicate]

The path for the Python executable used in Blender (up to 2.79) is not configurable. I looked around and did not find a consistent way to be able to use custom 3rd party Python modules without ...
1
vote
0answers
124 views

How to run Blender through VNC on Ubuntu?

I am using tightVNC to connect to an Ubuntu 18.04 server. When I try to start blender, I get the following error in the command line: ...
0
votes
2answers
136 views

Crowdrender Install?

Can someone walk me through how can I install the crowdrender add on in linux mint! When I try to install it, it gives me an error. Cheers,Frost.
0
votes
0answers
50 views

left click select not working in linux

my left click select isn't working under linux (tried several 2.8 builds over the past weeks). Still placing the 3D cursor, however right click brings up the quickmenu as expected. Works perfectly ...
0
votes
0answers
218 views

How do I change mouse sensitivity when using Blender (and not any other case) in Linux Mint?

I just set up a new Ryzen 5 2400G build and I'm trying to figure out how to run Blender with mouse settings that are different from my system settings. For example, in games I can set sensitivity for ...
0
votes
0answers
380 views

How do I get OpenCL with AMD RX 560 for Blender rendering? (GNU/Linux)

I'm sorry if this duplicate question is not allowed on stack exchange. I posted this in ask Ubuntu originally, but I figured I'd get a answer here. I'm trying to get back into Bender. The last time ...
0
votes
1answer
1k views

Blender 2.8 Beta will not run on Linux Mint. [closed]

Blender 2.8 Beta does not launch on Linux Mint Cinnamon 19.x I installed 2.7 to test (blender-2.79-f7e9642da9c9-linux-glibc224-x86_64.tar.bz2) and works fine. Basically download, extract and set ...
0
votes
0answers
283 views

Blender 2.79 not installing on linux

Experiencing some unclear problems with Blender 2.79, I uninstalled it with the intent to reinstall a fresh version using the same Linux mint Sylvia 18.3 operating system. Then realized that the ...
-1
votes
1answer
152 views

Ubuntu18.10 can't run blender2.80bate; but ubuntu18.10 in virtualbox can run blunder2.80

Ubuntu 18.10 can run Blender 2.79; Ubuntu 18.10 can't run Blender 2.80 Beta; (why?) But... VirtualBox(Ubuntu 18.10) can run Blender 2.80 Beta; (why?) ...
2
votes
0answers
890 views

How to install/use Blender 2.8 on CentOS 7.6?

I use Centos 7.6 and I am having issues to run Blender because there are problems with my libraries in my case "libmvec.so.1" is not found it seems that is due to the gclib version, I was looking for ...
0
votes
0answers
151 views

UBUNTU 2.80 version

Blender 2.8 Beta does not start with unser Ubuntu 18.04 LTS. Clicking the blender image does not work. Terminal says: ERROR: ld.so: object 'libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (...
0
votes
2answers
61 views

Clipboard Not Working on Ubuntu 18.04 in Blender 2.79b

Would anyone have any thoughts why my clipboard isn't working? It works in all other programs. I can copy text from other programs into Blender's Text Editor but I can't copy from within Blender? I ...
0
votes
1answer
138 views

OpenCL device only visible as root

I'm trying to enable gpu rendering on my Vega 64 card in linux, but I can only do so as root. When I run blender as root user, this is what I see in preferences: The first one will cause my whole ...
3
votes
1answer
3k views

Blender 2.8 cannot find libmvec.so.1

I am running CentOS 7 and I was trying to test the latest builds of Blender. However, every time I try running it, I keep getting the following error: ...
0
votes
4answers
855 views

OpenGL error on startup - Blender 2.80 - bumblebee

i can't open Blender 2.80 since it tells me that it requires OpenGL 3.3 to run. Well, when i start it with my intel graphics adapter everything is fine, but it fails, if i want to start it via optirun ...
3
votes
1answer
965 views

Blender on Linux - list of AMD GPUs that work with Cycles/OpenCL [closed]

Which AMD GPUs are useable with a recent Linux, more specifically Ubuntu (18.04) and AMD drivers? Or are there some that definitely don't work? This question is not off topic because either a GPU ...
1
vote
1answer
208 views

Linux Ubuntu 18.04 - Sculpting performance (dyntopo) is terrible in comparison to Windows

OS: Ubuntu 18.04 CPU: i5-6600K GPU: GTX 970 RAM: 32 GB Sculpting on objects with more 100k polygons (dyntopo constant detail 50 px) lags blender, especially using Snake Hook brush and dragging ...
1
vote
0answers
660 views

Blender 2.79 Cycles OpenCL RX Vega GPU extremely slow. (Ubuntu 18.04)

I am running Ubuntu 18.04 on a fairly powerful PC (Ryzen 2700x and Vega64) I finally managed to get OpenCL to work at all with ROCm-rehl drivers. When I render the default cube scene CPU rendering ...
1
vote
2answers
2k views

How do I get Blender working with AMD OpenCL on Linux?

I am using Arch Linux and am trying to use GPU Rendering in Blender. In the Arch Linux Wiki from Blender I read that I need either the AMDGPU-PRO or the opencl-amd package. So I installed the opencl-...
2
votes
2answers
3k views

Could not open file for writing?

I have been using blender for a few years and this is the first time I have come across this problem. I am running 2.79 on Ubuntu. I was trying render a short test video for a new project and I came ...