0
$\begingroup$

I have an object whose physic is Rigid Body, and I set its collision bounds to Convex Hull (else it would collide with its own children) but now it doesn't move when I play, and doesn't even fall on the ground.
Movement is force applied to the object when I press the correct key (W, A, S, D or Space for jumping)
Rotation works fine though, I don't understand why this is happening.

An automatic turret that shoots "on sight" in the same scene is having the same problem

Edit:

Here is the .blend file.

$\endgroup$
  • $\begingroup$ The Collision Bounds describes the physics shape rather than the behavior. Physics Type (Rigid Body) describes the physics behavior, which sounds correct to me. I'm a bit confused why you physics object has children with enabled physics. That might be the source of your issues. $\endgroup$ – Monster Sep 1 '16 at 4:19
  • $\begingroup$ actually it collides with a projectile that is instantiated on click event and might collide with the object (some kind of tank) and that's not expected... $\endgroup$ – joH1 Sep 1 '16 at 17:09
  • $\begingroup$ You add an projectile (rigid body I guess) and this one should not collide with the tank object? Isn't that the purpose of a projectile? $\endgroup$ – Monster Sep 2 '16 at 4:31
  • $\begingroup$ yes that's the point, but it collides on instantiation, with the parent tank, and that's not wanted $\endgroup$ – joH1 Sep 3 '16 at 9:09
  • $\begingroup$ I suggest to emit the projectile outside of the tank e.g. shortly in front of the barrel. (You do not need to emulate real world physics). $\endgroup$ – Monster Sep 5 '16 at 6:30
1
$\begingroup$

Enable Physics at your material.

enter image description here

Hints (outside of the question):

  • You named your objects and bricks - I like that. It was really helpful when looking at the scene.
  • The meshes have way too much faces for a game. They do not need that many for that little detail. I strongly suggest to remove the subsurf modifier(s). You can use smooth shading instead.
  • The floor creates projectiles. This was really distracting when analyzing your file. I would not expect a floor to behave this way. A separate object (e.g. called RandomProjectileSpawner) could do that job. You can add/remove it without loosing the scene's floor. You could even have more than one.
  • The dimensions of the projectile's physics shapes are way too large. They collide with the physics mesh of object Ship right after creation. I suggest to enable collision bounds at the physics tab on the projectiles. A box shape should be good enough.
  • Be aware the physics engine has problems with small travelling objects. It might happen that they do not collide with another face and suddenly are inside of an object, or that a collision does not get registered.

I hope it helps

| improve this answer | |
$\endgroup$
  • $\begingroup$ thanks, totally works now! (though some shells go right through the crate now but it doesn't truly matter ^^) $\endgroup$ – joH1 Sep 7 '16 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.