6
$\begingroup$

Here goes with the scene, The simulation did "explode" while another rigid body is inside, the gap I gave was big enough and the collision margin tried 0.000001/0.00001/0.0001/0.04/1 and convex hull or mesh, that's going wrong too :(

Video Link : https://vimeo.com/729547384

Gap Between Fracture Rigidbody and Inner rigidbody

Question :

  1. How to avoid "Push apart" happening while a rigid body is inside so the fracture cells could collide with the rigid inside and fall naturally?

Remarks :

  1. I would like to have the simulation from the "expected sim" with the rigid body inside collide correctly.

  2. The "Expected Simulation" is without an inner rigid body enabled.

  3. I am welcome for any concept or tutorial that will open my mind!

Blend File if required https://we.tl/t-QYj2c4E53c

$\endgroup$
5
  • $\begingroup$ make sure the Collision shape is Mesh and Sensitivity Collision Margin is zero for all objects $\endgroup$ Jul 13, 2022 at 10:40
  • $\begingroup$ Still results the same :( $\endgroup$
    – Ying Zhi
    Jul 13, 2022 at 10:46
  • $\begingroup$ yes i did , but the rigid inner still makes the fracture "explode" Here was the setting imgur.com/a/amWVVzS $\endgroup$
    – Ying Zhi
    Jul 13, 2022 at 11:01
  • $\begingroup$ something weird. your weights also seem unrealistic, i see a weight of 10,000 kg too much. and it acts weird when i change the weight to 1kg $\endgroup$ Jul 13, 2022 at 11:15
  • $\begingroup$ yeah, struggling to solve the problem . Thank a lot ! $\endgroup$
    – Ying Zhi
    Jul 13, 2022 at 11:27

1 Answer 1

5
$\begingroup$

First of all, you have to understand what "convex hull" means:

The resulting shape is something, if you would wrap your mesh with a tape.

I added here a geometry nodes setup to one piece so you see what convex hull makes out of your mesh.

enter image description here

So of course every single piece of your outer cylinder would intersect with your inner cylinder, because you set it to convex hull.

And every intersection of two rigid bodies in a simple world like Blender physics isn't possible (and also not in real world if you exclude deforming). That's why it explodes.

So set them all to mesh, scale them down a bit, play a bit with settings (e.g. use "normal" weights, not that huge as you took, turn down margin to 0, lower bounciness...) and then finally you might get:

enter image description here

repaired file to check out:

$\endgroup$
11
  • 1
    $\begingroup$ Thank for the details explanation. appreciate the answer , you help a lot! $\endgroup$
    – Ying Zhi
    Jul 13, 2022 at 12:47
  • 1
    $\begingroup$ If my answer helped you, please click on the checkmark left of my answer. Thank you. $\endgroup$
    – Chris
    Jul 13, 2022 at 12:48
  • 1
    $\begingroup$ i did exactly that, but it still explodes. i even reduced the size with visible gaps blend-exchange.com/b/7BdGb7L7 $\endgroup$ Jul 13, 2022 at 13:09
  • 1
    $\begingroup$ make them just a little bit smaller, change substeps and solver to 10 then it worked for me [1]: i.sstatic.net/hCwO7.gif i scaled them to 0.964 $\endgroup$
    – Chris
    Jul 13, 2022 at 13:17
  • 2
    $\begingroup$ and blender physics is pretty "limited" - just e.g. i never made a physics simulation better or working by increasing substeps...in contrary to cloth where increasing quality is working most of the time. The more complicated the meshes are...the less Blender physics would work. So you should try to keep objects "simple" ;) $\endgroup$
    – Chris
    Jul 13, 2022 at 13:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .