2
$\begingroup$

enter image description hereI am using Blender for research purposes, analyzing eye movements of participants watching a movie. This can be done with blender and DynAOI: Add an object as Area of Interest in Blender (setting the movie as background image, then modeling an object over the person you're interested in) and then DynAOI matches weather participants were looking at or away the AOI.

The problem is that we need a 3D-object to match eye movements to, but it should actually only have 2 Dimensions - that is, eye movements were recorded along x and y axis, but not z (unfortunately it is not possible to match eye movements to a circle, because the program needs a 3D object).

Is there a way to do this? I tried setting scale of object Z to 0, but it does not seem possible to set Scale Z of object to 0 for the duration of the complete film scene. And it would take hours to set it to 0 for the duration of the complete scene we're interested in.

$\endgroup$
4
  • 1
    $\begingroup$ How are you setting the scale to zero, could you provide some screenshots? When you scale an object to zero it should stick for the whole duration of an animation, unless the scale is key-framed, and has other values $\endgroup$ – Duarte Farrajota Ramos Aug 6 '16 at 12:29
  • $\begingroup$ Thank you for responding so quickly! yes I needed to set keyframes for the movement of the object throughout the film scene. $\endgroup$ – user29246 Aug 6 '16 at 17:12
  • $\begingroup$ Try editing the f-curves for the animation. $\endgroup$ – someonewithpc Aug 6 '16 at 17:16
  • $\begingroup$ in the curve editor you can select the Z axis and delete all keyframes or scale them to 0 $\endgroup$ – user1853 Aug 6 '16 at 17:17
1
$\begingroup$

You could try to go in edit mode, and then select the vertices you don't mind (press C and then use the circle to select them) and then delete them by pressing X and the option "vertices". Otherwise I think that for make the eye moving you need key-frames. If you selected the option LocRotScale every time you reach the key-frame, it set the location (Loc), the rotation (Rot), and the scale (Scale) of the object to the value it had when you have set the key-frames. So basically you have to delete them, set the Z scale of the object to zero, and re-set the key-frames. To delete the key-frames, select the object, go on the frame on which there is the key-frame, and press Alt-I. Hope helps.

$\endgroup$
3
  • $\begingroup$ Thank you! The problem is that it took a lot of hours to set the key-frames, can I copy them somewhere and paste them after setting Z scale of the object to zero? $\endgroup$ – user29246 Aug 8 '16 at 8:58
  • $\begingroup$ Well you can save a copy of your file and so you have a copy of the key frames, but it will result veeery long to past... @user29246 $\endgroup$ – Fly_7113 Sep 4 '16 at 20:54
  • $\begingroup$ The numpad plus key lets you add a number to your filename or increases an existing one when you save. Having a bit of backup is always a good thing. But chances are your z scale is just x keyframes the same value. $\endgroup$ – Haunt_House Feb 4 '18 at 14:01
1
$\begingroup$

It looks like you have set a lot of key frames for location, rotation and scale. Your problem is that you have keys for the Z scale that you probably don't need.

While the object is selected, hover over the Z scale in the properties (Transform panel) and rightclick it. Use the menu item: Clear Single Keyframes. That will leave the x and y values intact (if you need them) and delete all the rest. The yellow or green color indicating keyframes should be gone.

Then fill in 0 into the Z scale and you should be done.

It's usually preferable to only key the aspects of your mesh that you need, like location and maybe rotation.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.