3
$\begingroup$

I am trying to make a fluid simulation flow out of the orbits of this skull (I hope this doesn't violate any guidelines), as a little experiment / practice with fluid simulation.

enter image description here

The result is not too bad, but the liquid flows through the walls of the skull, on the left/right temples as well as the nasal cavities.

I have read that in order to prevent that from happening, thickening the obstacle was a good solution. However, when I thicken the skull I get a very crude (albeit somewhat funny) result:

enter image description here

Ideally, I would like the fluid simulation to be not only realistic, but the container / obstacle as well!

Also, for some reason, I feel that the liquid should flow out a little sooner than it does. I'm not really sure how to troubleshoot fluid simulations, and the questions I have found so far didn't help.

Blend:

$\endgroup$
  • 3
    $\begingroup$ The fluid looks very low resolution in your gif. Does the interaction improve at higher resolutions (be aware that the size of your domain affects the practical resolution of the fluid) $\endgroup$ – gandalf3 Apr 16 '16 at 2:49
  • $\begingroup$ I tried changing resolution to 300 and then 200 (that's why I answer to your comment 6 hours later lol), but the result was not better or worse (liquid flowing through obstacle then up through the eyeholes). If you want, feel free to try a setting to make the obstacle 100% waterproof, it will be much appreciated, I find hard to understand how "obstacles" work (or don't!). Thanks for your help! $\endgroup$ – MicroMachine Apr 16 '16 at 9:28
  • 1
    $\begingroup$ With a domain that large, I suspect you'll need much higher resolution than even 200. I shrunk your domain down a lot and it seems to be working better (resolution is set to 150 in this screenshot). $\endgroup$ – gandalf3 Apr 16 '16 at 17:08
  • $\begingroup$ It looks like the domain is actually bigger in your first screenshot? Could you post the file or your settings? $\endgroup$ – MicroMachine Apr 17 '16 at 20:04
  • $\begingroup$ Here's the .blend $\endgroup$ – gandalf3 Apr 17 '16 at 20:27
7
$\begingroup$

First of all, you should make sure that the basics of the fluid sim are set up correctly.

  1. The domain should not be larger than necessary. The larger the domain, the more resolution you need for equal quality. You are just wasting baking time.

  2. Scale should be applied (Ctrl+A) to the domain and the obstacle. Otherwise the results are somewhat unpredictable. This is usually the first step in troubleshooting a fluid sim.

  3. There is no point in having a preview resolution of 100. You will always want to look at the final version, not the preview one, so to bake it at a high resolution is just more wasted baking time. Some people like to set the preview resolution to 1 because of this. But if you want to look at your animation before rendering to check the timing of camera movements, or whatever, something like the default 45 will do the job.

  4. There is never ever a need for 4 subdivisions in the fluid boundary settings. At high resolutions (maybe about 300+) or if you want fluid particles, it should be set at 2, otherwise zero. You are just increasing the baking time without getting anything in return.

Now, if you have done all that, there is one more simple thing to do to prevent leakage. In the fluid boundary settings, uncheck Remove air bubbles. With this setting checked (which is the default), the fluid sim will basically avoid to have any space between the fluid and an obstacle, thus preferring to pass through. With high enough resolution this setting does not matter, but at low resolutions, very much so.

I hope that helped.

$\endgroup$
  • 1
    $\begingroup$ The preview resolution setting theoretically doesn't affect bake time (at least not significantly, relative to the time needed for everything else), as it's calculated by down-sampling the full resolution sim. I typically like to set it around 80 or so, then I can usually get the preview to play back in real-time on my machine. $\endgroup$ – gandalf3 Apr 17 '16 at 20:33
  • 1
    $\begingroup$ Thanks for clarifying that. I just repeated what I've heard in a bunch of tutorials without ever having bothered to check for myself. It is too bad that the baking does not present you with the time it took, unlike a render. Then it would have been easy to experiment with the settings and see how they actually affect baking time. $\endgroup$ – Jbergman Apr 17 '16 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.