2
$\begingroup$

I am trying to make a simple liquid simulation of a liquid going down a carved path on the ground.

enter image description here

I can't seem to make the liquid flow along the obstacle, all or part of it always seem to hover above the obstacle or have a gap / margin between the obstacle and the fluid. It produces shadows and artifacts that are neither realistic nor aesthetic, which I would like to iron out.

enter image description here

This is what I tried:

Obstacle Material: the obstacle had a rather complex material with bump maps, which I thought could be the cause for these gaps, so I changed the material. Still nothing.

enter image description here

Subsurface on the obstacle: the obstacle also had a subsurface (not really sure whether or not this should be taken into account when creating fluid simulations), so I applied the Subsurf to the obstacle and re-baked. Problem is still here.

enter image description here

Increasing resolution: This is where I get a bit confused. I can get good results with low resolution (50) and quick playback: the liquid adheres to the obstacle rather well. When I increase the resolution to create a final export, the result is very different and the gaps are back.

I have also:

-applied scale to all the objects in the scene,
-fitted the domain to the elements as best as I could,
-made the obstacle a shell,
-tried alternatively Honey / Oil / Water settings,
-tried to change Slip settings to Free Slip / No Slip / Partial Slip for obstacle or domain,
-solidified the obstacle,

but nothing really fixed this problem. I want the liquid to fill the shape I designed like a normal, real liquid.

.blend:

$\endgroup$
3
$\begingroup$

The obvious answer is to increase the resolution, but while this will make the problem less noticeable, there will still be some of this "mushrooming effect". Furthermore, with increased resolution the behaviour of the fluid changes. It becomes more "splashy" if you know what I mean. I baked your sim at a resolution of 300, and the fluid splashed all over the place.

What you will then have to do is that once you have baked the sim, you move your domain downwards (or the obstacle upwards) and maybe do some slight stretching of the domain until these artifacts disappear.

Anything else won't matter. However, about some of your comments:

You say that it looked good with a resolution of 50, but I baked it and it looked horrible. Most likely your observation was due to some other factor, such as not having applied the subsurf modifier.

Yes, about the subsurf modifier. The fluid will ignore the modifier unless it is applied. It will just react to the obstacle mesh as it is. In your case, this might have covered up the problem, as the subsurf decreases the volume of the "canal". A lot of fluid will thus be hidden inside the obstacle, so to speak.

Good luck!

$\endgroup$
0
$\begingroup$

I have found gaps to occur when all objects scaling is out of whack.

maybe try seeing if the bone/armature and/or object itself that is the obstruction is at scale 1.000

I was editing my own scene and found this to be the case.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.