1
$\begingroup$

In this project, water is leaking from the walls of the waterwheel and it doesn't look realistic at all. I tried so many possibilities but nothing worked. please help me to make the water looks realistic. I'm really grateful for anyone who could help me with this Herewith I've shared a link for a blender google (google drive) -

https://drive.google.com/file/d/1pmJ7dQF6zz4SSzpXclHlWIR4nWDZ8R3A/view?usp=sharing -Thanks- enter image description here

$\endgroup$
  • $\begingroup$ So... It has nothing to do with texturing, but with physic simulation. Half of the issues with obstacles are either because of a wrong volume initialization (usually you need to use "shell") or because of not enough resolution. $\endgroup$ – L0Lock Dec 21 '18 at 10:53
2
$\begingroup$

I had a quick look at your scene. So here are a few hints, maybe this won't fix your issue but this will surely enhance your life working with this scene. (But the points 2. and 3. are part of the issues anyway, so they might solve it.)

  1. 450 as render resolution and 40 for the viewport is really low.

Those two aren't enough. 40 is way too low to show you something even close to what you're going to, crank it up, start from 128 and see from there. 450 is also a low value, but you'll see what you need.

  1. Your domain's scales are insanely wrong and inverted.

Your fluid simulation (including resolution) are directly linked to the scales. You have to apply them with CtrlA menu in object mode (and as they are inverted, you will also need to invert the normals via CtrlN in edit mode)
While you're at it, also check any other object's scale the same way. Always avoid inversed scale or uneven scales, unless you really need them and know how to work with them. If you're in doubt, select everything and apply scale on everything.

  1. Your watermill has no thickness on its sides.
    The big circle shapes are made of a flat surface without any thickness. This cannot work properly as a physic simulation's obstacle. Add some thickness via extruding those circles.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.