2
$\begingroup$

I've done this before and it worked fine, now I don't know if I've hit a key by accident and changed something but it won't work now. This is done using CTRL+B after selecting the 4 edges around the cube.

What I'm trying to do:

What I'm getting in my model:

The 1st image is a bevel of the original starting cube in a new/seperate blender program. The 2nd is when I add a cube to the model I'm working on and try to bevel the 4 side edges. The bevel options are set exactly the same (offset-type, loop-slide, etc.)

I noticed when I did the bevel in the 1st image, that if I kept dragging the bevel out (to a higher offset?) it would start to look like the 2nd image. It's almost like I don't have the first bit of fine beveling (1st image) it just goes to the extreme (2nd image)

EDIT: It does seem to have fine movement at the beginning of the drag bevel, it just doesn't "cut" the corners. Instead, it pulls the edges in towards eachother then when they meet in the centre of the face, it starts to do what my 2nd image shows. I'd post a link to what I mean by this, but I can't post more than 2 links..

Any ideas??

$\endgroup$
  • $\begingroup$ Another way to get this shape is by adding a circle or cylinder and setting the number of vertices to 8 $\endgroup$ – gandalf3 Apr 3 '16 at 22:55
2
$\begingroup$

There are two things that can be happening:

  • The object has probably been scaled in object mode, but the transformation was not applied (CtrlA in object Mode).

    When the transformations are not applied, the scale for transformations in edit mode can get completely out of whack.

    Read this related posts:

    Why do the measurements of this object seem erroneous?

    Why is it important to apply transformation to an objects data?

  • (probably because of the reasons above) You are using a large bevel value, the transformations are being multiplied by the scale of your object giving you a value that is much larger than the object itself, creating errors.

    enter image description here

The fix is applying your scale in object mode, or using Percent as the amount type for the bevel making the transformations, that will allow you to have more control and prevent you from beveling past 100%.

enter image description here

(But even if you do that. Start getting into the habit of applying transformations in object mode.)

$\endgroup$
  • $\begingroup$ Thanks for the quick reply, using percent as the amount type of bevel worked perfectly! I might have scaled the beginning cube to my model in object mode, instead of edit, without applying the scale but I can't remember. Would I be safe to go into object mode now, select all of my model, then apply scale? $\endgroup$ – DUFF3RR Apr 3 '16 at 19:49
  • $\begingroup$ Apply the scale and do read the links on the answer. It will save you a few headaches. Happy blending. $\endgroup$ – cegaton Apr 3 '16 at 19:50
  • 2
    $\begingroup$ It could be also useful to bevel with Clamp Overlap turned on in Bevel options. $\endgroup$ – Mr Zak Apr 3 '16 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.