4
$\begingroup$

For some reason I can't seem to select a sword that I duplicated from a previous one. The previous sword is still selectable but the duplicated one is not. For some reason blender selects whatever is behind the object. However I dragged a box over it about 20 times and found that it worked once, but it selected everything with it.

$\endgroup$
  • $\begingroup$ If you could upload a .blend file, that can help us experiment to see what is the issue with your project. $\endgroup$ – GiantCowFilms Jan 6 '16 at 19:54
3
$\begingroup$

Check to see if it is listed in the Outliner. If it is, click on it's entry. If it still won't highlight, check to see if the arrow icon is toggled. Click it to make sure it's not greyed out. This indicates whether an item is selectable.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ the outliner actually does say both swords are parented to the same character but i can't seem to make it clear parent $\endgroup$ – A guest Jan 7 '16 at 17:32
  • $\begingroup$ Do you have any modifiers on the sword? Also, can you add a screenshot showing your Outliner? Thanks $\endgroup$ – Ben Mora Jan 11 '16 at 15:39
3
$\begingroup$

There are some possible reasons:

  • You duplicated the mesh in edit mode, but the object is still the same. See if your swords appear as separate objects in the Outliner.
  • Your duplicated object was somehow marked as unselectable. See if the pointer icon is active in the Outliner.
  • There's one or more objects in front of the one you're tying to select. Try to move your view port around and select your object from a different angle.
| improve this answer | |
$\endgroup$
0
$\begingroup$

If you have backface culling checked off in the object's Shading menu, you may need to flip the normals.

Change your viewport to the solid rendering mode and see if the object disappears from your viewing angle but is visible from the opposite side.

If this is the case, you'll need to flip the normals in edit mode.

| improve this answer | |
$\endgroup$
0
$\begingroup$

In the outliner if you accidentally type while renaming (without having renaming properly started) you can mess up the selection enabled flags.

Type 'a' to 'select all' (in the outliner) and then 's' to re-enable the selection enabled icons (arrows between eye and camera).

| improve this answer | |
$\endgroup$
0
$\begingroup$

I solved this problem by going to main menu Edit > Preferences > Keymap then 3D View section and on the right was an option to Reset and it fixed the problem.

Now I can choose objects back in Object Mode as usual.

enter image description here

| improve this answer | |
$\endgroup$
0
$\begingroup$

I recently had the same problem I couldn't highlight it in texture mode.

What I did since I could select it in the Outliner was duplicate it then delete the old one, and rename the new one.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.