I'm creating animation with shooting gun.

I've created gun model, smoke emitter which is placed at the end of the barrel and muzzle flash - volume shader with emission.

Everything looks fine until the smoke starts to flow out the barrel cause you can see 'muzzle flash' which looks like big black spot inside, even when volume density is 0.000.

Another problem is that smoke also affects muzzle flash when volume density is 1.000 there are transparent deformations which causes holes in flashing object.

It looks like smoke is ruining everything in my animation. Because without this effect everything looks really cool.

I've tried to separate gun, smoke and flash. I can easily render each of those but rendered together causes same problem (gun with smoke - good, gun with flash - good, flash with smoke - bad, gun with flash and smoke - big fail) .


I still don't know how to fix this. Maybe it's just a bug and that's why I'm asking: Do you know how to solve this problem or maybe just how to separate layers? And why smoke and emission (even if it should be 'transparent') affects each other so much?

By the way - I'm working with Blender Render.

  • $\begingroup$ It seems as if the transparent part of your material is not getting deep enough into the geometry. You should try adding a mix node with a transparent shader and see if it stops the cutoff of the smoke. $\endgroup$
    – Yvain
    Aug 16, 2015 at 1:34
  • $\begingroup$ Simple transparent shader works well I mean that if alpha is set to 0 smoke looks good and shader too if alpha is set to 1 - the problem is that i can't use alpha in transparency options because I'm not using Surface (where it is possible) but Volume shading where density defines 'alpha' (not 100% sure) and volume density causes problems with smoke and shader itself (black spots). I mean everything would be fine if i use simple shader but muzzle flash looks better if it's volume. By the way - mixing nodes is only possible in cycles or maybe I don't know about something. $\endgroup$
    – Michael
    Aug 16, 2015 at 8:44

1 Answer 1


It looks like i've solved my problem. I've changed muzzle flash volume object that was appearing and disappearing - now it's a paricle emitter. Particle lifetime is just one frame so it looks pretty similar to previous effect. Smoke is not hidden anymore because there is no object that could do this - particle emitter surface is not visible and muzzle flash particle is there for very short time.

Strange thing is (which I've not expected when i was thinking about this solution) that particle - which is an object with volume shader - is not bugging anymore! I mean there is no black deformations inside flash object even when all objects are on the same render-layer.

This funny trick fixed my problem but it will probably still exist if someone try to render smoke and volume object inside which is not moving or disappearing - black deformations on volume and hidden smoke when volume density is set at 0.000.

enter image description here

I hope this will help somebody.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .