6
$\begingroup$

I am following Andrew price's video on making clouds but my clouds are rendering with black spots on them. I have tried turning up the maximum transparency value under light paths but there is no difference between 50 and 200.

enter image description here

What could be causing this?

$\endgroup$
6
$\begingroup$

These are caused by self-intersecting bits of the cloud particles showing the backsides of faces to the outside world:

enter image description here

Rays going through the back of a face don't count as going into the volume, and so appear mostly transparent.

To fix this you have a couple options:

  • Lighten up on the displacement to avoid such intersections:

    enter image description here

  • Or add a remesh modifier (and optionally a decimate modifier to keep the vertex count down)

    enter image description here

$\endgroup$
  • $\begingroup$ Ah, thanks. Lowering the displacement strength worked perfect. $\endgroup$ – Qwertie Apr 15 '15 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.