2
$\begingroup$

After applying a boolean modifier, I'm getting these jump lines that connect a cut out to the outer perimeter. In other contexts I've made an object that has an inner and outer set of edges without needing jump lines, so I know they aren't required.

Things I've tried:

  • Decimate: doesn't do anything, not sure why
  • Geometry node to delete any edge touching more than one face: doesn't work either
  • Array modifier with merge: if they were separate objects, thought it might connect them.

Why aren't any of these things working? Are they two separate objects? Or are these edges required for some reason?

Link to project: https://drive.google.com/file/d/1bwJPsTbevJnwmZHqWX0w--ps08eraqHK/view?usp=sharing enter image description here

Edit: I did find this similar question and the answer states you can't have holes in a face in blender. I have an object in my project (linked above) that seems to have a hole in the face: enter image description here

EDIT 2: This is me applying the same wireframe geometry node modifier to each face. One of them is creating jump lines and the other is not. Both faces are totally flat. enter image description here

$\endgroup$
5
  • 1
    $\begingroup$ Yes there is a trilion answers for this topic blender.stackexchange.com/a/211249/2214 $\endgroup$
    – vklidu
    Dec 6, 2023 at 8:34
  • $\begingroup$ I think it's reasonable to call this a duplicate.. Blender's faces do not support holes, or even a single edge used twice in the same face, so 2 connecting edges are required. $\endgroup$
    – Robin Betts
    Dec 6, 2023 at 9:06
  • $\begingroup$ @RobinBetts For the main question I'd call this duplicate, too. For what is shown in the end (holes without connecting edges), I wrote an answer which might be the solution but I wouldn't mind closing this question as duplicate. $\endgroup$ Dec 6, 2023 at 9:16
  • $\begingroup$ Hello, @GordonBrinkmann and Seph, fair enough.... agreed. Sorry, I hadn't read into the second part the way you have, I'll re-open. $\endgroup$
    – Robin Betts
    Dec 6, 2023 at 9:47
  • $\begingroup$ Thanks for keeping it open. I did find people saying it's impossible, but I've managed to achieve a wireframe that acts on edges and somehow allows a hole in a face. So something is possible, not sure what. $\endgroup$
    – Seph Reed
    Dec 6, 2023 at 15:16

2 Answers 2

2
$\begingroup$

... any hole in face (surface) is connected by two edges. Your "cubish" object is not generating them in final stage, because you delete them by geometry nodes.

To answer your Q in title ... basicly you have a node tree that removes them already, but from your node tree it seems to me you are not sure what these nodes do.

For your second "spherical" object you can use just this simplified node-tree ... where the selection for Delete Geo node is based on Edge Neighbors which is limited by Greater Than node to select any edge belongs to more than one face.

enter image description here enter image description here

$\endgroup$
1
  • $\begingroup$ "it seems to me you are not sure what these nodes do" the project file name is "learn-geometry-nodes" :p. This is my first time. $\endgroup$
    – Seph Reed
    Dec 7, 2023 at 4:17
4
$\begingroup$

The answer linked in the commentary to your post is correct, faces cannot have holes within them, so each hole needs a minimum of two faces around it or put differently: a hole needs at least two connecting edges to surrounding geometry.

You say you have an object that "seems" to have a hole in the face. At first glance, without seeing more of the viewport I could not even tell if this is Wireframe mode or Solid and there simply are no faces, just edges.

But I suppose you have seen it in Solid mode and know there are faces. Did you go into Edit Mode? Are there really no connecting edges?

For Object Mode, there is a Wireframe setting in the Overlays. Behind the checkbox there is also a slider where you can change the value from 1 down to 0. All the way up to 1 it shows all edges in, decreasing the value lets edges disappear where the angle between the adjacent faces is below a certain threshold. The lower the value, the higher angled edges are hidden.

On a completely flat object, even the slightest bit lower than 1 makes all inner edges disappear, compare the left side with 1 to the right side with 0.999:

edge visibility

//EDIT: Regarding the additional information in your question: Sorry, but you did not create holes in faces without connecting edges. If you disable the Geometry Nodes modifiers and look at the base geometry in Edit Mode, there are lots of connecting edges around the hole:

holes connected

You are not even using any kind of Mesh Boolean node inside the nodetree or any Boolean modifier outside and no Wireframe modifier either to achieve the result.

The only reason you don't have connecting edges in the "wire" is that you delete all geometry that you don't want to have a wire in the second Geometry Nodes modifier.

So if you would do something like that with the other object in your question instead of simply cutting holes with a Boolean modifier and throwing a Wireframe modifier on it afterwards, you could achieve the same result without connecting edges.

$\endgroup$
6
  • $\begingroup$ ...I find it funny that everyone says "Blender can't create faces with holes without connecting them with edges". Geometry Nodes can do that: two curve circles with different radii > Fill Curve. $\endgroup$
    – quellenform
    Dec 6, 2023 at 10:01
  • 2
    $\begingroup$ @quellenform Would you mind showing how you do this? When I fill the curve between two curve circles with different radii it looks like this in Wireframe mode: i.stack.imgur.com/eVlyR.jpg $\endgroup$ Dec 6, 2023 at 10:11
  • 1
    $\begingroup$ Uh, no, unfortunately I can't because I just realized that you caught me and that it was only in my stray memory that it was possible :D ...so you can be wrong (embarrassing) $\endgroup$
    – quellenform
    Dec 6, 2023 at 11:23
  • $\begingroup$ Both of the objects are completely flat to my knowledge. Also, when putting both through the node modifier to add cylinders to each edge, it does not create them for the boxy one. Somehow it is possible to ignore those jump lines, and it doesn't seem to just be flatness. $\endgroup$
    – Seph Reed
    Dec 6, 2023 at 15:11
  • $\begingroup$ I added an edit to the original post to show the wireframe modifier ignoring those jump cuts in one object, then using them in another. $\endgroup$
    – Seph Reed
    Dec 6, 2023 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .