1
$\begingroup$

Currently, I am trying to do texture painting for my model. However, there are pixel gaps in my texture when I try to paint on the model from the 3D viewport, but not when painting on the UV map directly.

Comparison

They appear to be pixels on the UV map itself, with consistent pixel sizes. I have tried scaling the model itself, but that did nothing to help. The pixel size seems to be fixed based on the UV and does not change whether I zoom in, out, or paint from different angles. I have tried opening a new file and painting on the default blender cube, but that had no issue. But when I appended the model from the original project to the blank project, the problem returned, making me assume it was a problem with the model.

Close-up

If it helps with anything, the texture size is 2048x2048.

Any help will be appreciated. Thank you very much in advance.

Edit: Link to the file https://www.mediafire.com/file/y6wwgmei7kst84y/Test.blend/file

$\endgroup$
2
  • $\begingroup$ Hello could you please pack your image and share your file? $\endgroup$
    – moonboots
    Jul 8, 2023 at 9:54
  • $\begingroup$ I have edited and attached the file to the end of the post. $\endgroup$ Jul 8, 2023 at 10:29

1 Answer 1

0
$\begingroup$

You are using a Mirror modifier but your object is already symmetrical, so the artefacts we see are simply overlapping faces (faces of the original object + faces of the mirrored object). You need to either remove your Mirror modifier, or keep it but remove half of your topology.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .