0
$\begingroup$

What lies behind this picture of a dolphin is a mesh set to be a shadow catcher, so it can effectively product an image floating in space. I understand that in Blender 3 the shadow catcher function seems a little different than earlier versions. Is it rendering in a separate layer? Because I only see one.

Under "combined", it has a "ShadowCatcher" layer.

I notice that when I turn off the Denoise option, the shadow appears in the render.

enter image description here

enter image description here

enter image description here

enter image description here

$\endgroup$

1 Answer 1

0
$\begingroup$

When you see the Shadow Catcher pass in the render window's dropdown menu under Combined this means you have the Shadow Catcher pass enabled, which you find at View Layer Properties > Passes > Light > Other.

shadow catcher pass

In this case, the Shadow Catcher will not be showing directly in the render but is a separate pass which you can use in the Compositor. For example to make it brighter or darker or color it somehow, or use it as some kind of mask etc.

shadow catcher pass in compositor

If you do not want this and simply use the shadow catcher as before, disable the pass in the View Layer Properties and then the shadow will be fixed in the rendered image. In this case if you want to composite the shadow with a different brightness or color etc. you have to mask it out manually.

compositor without shadow catcher pass

$\endgroup$
5
  • $\begingroup$ I actually don't have "Shadow Catcher" enabled under View Layer... I see the shadow appear as the scene is rendering. But when I do turn on "Shadow Catcher", no shadow appears at all during the render... or after. I've notcied that when i disable "Denoise" under Render Properties. $\endgroup$
    – Matthew
    Apr 27, 2023 at 20:29
  • $\begingroup$ @Matthew Hmmm, that's strange. The Shadow Catcher shouldn't be available under Combined if the pass is not enabled... and I use Denoise as well, but the shadow is there. Maybe you have to upload your file? Is it just this file or in a completely new created scene too? When you turn on Shadow Catcher under Passes it is normal that you don't see it while rendering or after. It is then only available as a separate pass (as I explained in my answer). $\endgroup$ Apr 28, 2023 at 5:44
  • $\begingroup$ I simply want the shadow catcher to appear fixed in the final rendered image. I don't want to have any use of the compositor for this process. $\endgroup$
    – Matthew
    Apr 28, 2023 at 13:52
  • $\begingroup$ When I disable "Denoise" under Scene, the shadow catcher appears in the render. So this has something to do with the denoise! $\endgroup$
    – Matthew
    Apr 28, 2023 at 14:28
  • $\begingroup$ @Matthew But it shouldn't have to do with the Denoise and in my latest and previous versions it didn't have an effect. That's why I already asked you to share your file to investigate it further because just from what you say I cannot reproduce this issue. $\endgroup$ Apr 28, 2023 at 15:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .