3
$\begingroup$

I am using the New Shadow Catcher from Blender 2.79 and would like to know how do I leave the most intense shadows? I'm trying to adapt my model, as close as possible to the background image...

enter image description here

This is my setup scene...

enter image description here

And i'm only using a Point Lamp with this configurations...

enter image description here

Dont have problems/bugs, I just want to increase the strength of the shadow in the scene.

enter image description here

EDIT: The problem has been solved by adding the Color Ramp! Now my shadows grew more intense. Thanks!

$\endgroup$
  • $\begingroup$ To help you better, please add some more detail on how you are creating the shadow in the first place. Are you using the new shadocatcher on 2.79? $\endgroup$ – cegaton Sep 14 '17 at 1:50
  • $\begingroup$ Yes, yes I'm using it! $\endgroup$ – Sérgio Wilker Sep 14 '17 at 1:51
  • $\begingroup$ post the node tree you are using on the compositor. $\endgroup$ – cegaton Sep 14 '17 at 1:53
  • $\begingroup$ What tree node do you need? $\endgroup$ – Sérgio Wilker Sep 14 '17 at 1:57
  • $\begingroup$ compositing nodes $\endgroup$ – cegaton Sep 14 '17 at 2:09
2
$\begingroup$

You have rammed into a common issue compositors are facing. Actually there are two of them:

1) Your footage has been graded already

However that footage had been taken, may it be a simple iPhone camera or some advanced Blackmagic thing, judging from the look of the footage some kind of intensity mapping has already happened here. Keep in mind that if you're using the .jpegs the camera provides you for convenience always have some sort of intensity mapping applied, and it's a different one for each camera maker. That's why some images look Canon-ish and some are Nikon-ish. When compositing, ideally you work on the RAW footage, which hasn't been mangled that way yet. The values the camera had recorded, including the intensity of the shadows, has not been altered in RAW yet. In that case, Shadow catcher and scene would play nicer together, you could merge the layers and then apply the desired Grade. Again, in your case, I believe you don't have this option.

2) You don't have a clue about the lighting intensities on the original set

Judging from the shadows, you rightfully have seen that there is multiple light sources. However, how would you know how bright they were, and at what distances they were located? Both information is crucial for the shadows to be correct. Even the objects that were on the set caused light to bounce and therefore shadows to change. You won't have that either. You had no other choice than guess something together. What happens then is that one light source brightens the shadow another light source had cast. Also carefully watch your World material, as it also brightens the shadows.

So you're missing two keystones of proper compositing, and are stuck at guesstimating a fix. At least, there's a trick that might help you out.

possible workaround

For starters, here's a .blend file:

As mentioned here, the Shadow Catcher creates the look in the Alpha channel only. The shadow color is defined by the RGB channels, and those are pitch black already. It won't get any darker than that. So one option to change that look is to mangle the Alpha.

Let's have a look at the composite as you might have it right now:

current state

We use an Alpha Over node to merge foreground and background. The result is a somewhat bright shadow, because in my .blend I had used a World (intentionally, to create the issue). Now, work on the Alpha by throwing in for example a ColorRamp node like this:

possible fix

By doing that, you basically change the factor in which foreground and background are merged together. The solution isn't ideal as it will create Alpha fringes, but you might get away with it.

Another option would be to use the alpha as a factor for a node like HSV, to dim the composite down locally, but that requires you to separate shadow from object, like in the question linked above.

$\endgroup$
  • $\begingroup$ Hello! Just add the Color Ramp, solved my problem! thank you! $\endgroup$ – Sérgio Wilker Sep 14 '17 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.