1
$\begingroup$

So here I have my scene. The point light in the lamp looks great except for in the reflection, as you can see. I've tried to disable different visibility check boxes in the properties menu but that stops the actual light from reflecting on some other objects. Anyone have any ideas for fixes?

enter image description here

$\endgroup$

1 Answer 1

1
$\begingroup$

Since you're using cycles, you have the ability to control lights with nodes - enable this option and try using the shader graph setup bleow - mixing a Full strength Light Emission with a Zero Strength Light Emission using the inverse of the Glossy Depth output of a Light Path Node as a Mix Factor. In the image below, I left another light at its default settings (right side) for reference:

Light

$\endgroup$
3
  • $\begingroup$ Hey thanks for this, I didn't know light nodes were a thing. Only one issue: doing this gets rid of the yellow circle, but also some of the other reflections like the poster on the wall. If I'm asking to do something impossible, sorry. $\endgroup$ May 23, 2022 at 0:38
  • $\begingroup$ Ah, nevermind. This changes up the lighting, its not that it can't reflect off the poster, its just that it doesn't. $\endgroup$ May 23, 2022 at 0:46
  • $\begingroup$ Yeah, it's not perfect - other things with a high metallic value or even reflections may be affected - it can be a bit of a balancing act, unless you want to go the route of separate render passes $\endgroup$ May 23, 2022 at 0:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .